Bug 441601 - incomplete gnash-klash package
incomplete gnash-klash package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 18:10 EDT by Oliver Henshaw
Modified: 2008-04-28 12:59 EDT (History)
0 users

See Also:
Fixed In Version: gnash-0.8.2-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 12:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Henshaw 2008-04-08 18:10:51 EDT
Description of problem:
Trying the gnash-klash package from fedora 8 updates-testing, I find the kpart
plugin no longer works. After some investigation it became obvious that the
plugin library does not exist.

$ rpm -ql gnash-klash
/usr/bin/kde-gnash
/usr/share/apps/klash
/usr/share/apps/klash/pluginsinfo
$ grep X-KDE-Library /usr/share/services/klash_part.desktop
X-KDE-Library=libklashpart

Version-Release number of selected component (if applicable):
gnash-klash-0.8.2-2.fc8

How reproducible:
View flash site (e.g. youtube) with konqueror.

Additional info:

From an examination of the spec files in fedora cvs, the klash plugin library is
missing on F7, F8 and rawhide. To avoid a regression, the klash package for F7 +
F8 should not be pushed to stable until they are complete.

Arguably, klash should not be built at all for F9/rawhide until there is a
working kde4 version. This would need to be disabled before F9 final.
Comment 1 Oliver Henshaw 2008-04-08 18:28:27 EDT
Minor copy & paste whoops:

$ rpm -ql gnash-klash
/usr/bin/kde-gnash
/usr/share/apps/klash
/usr/share/apps/klash/pluginsinfo
/usr/share/services/klash_part.desktop  <--

of course.
Comment 2 Kevin Kofler 2008-04-09 13:28:01 EDT
IMHO, pushing an update with a known serious regression to stable was a really 
bad idea.
Comment 3 Patrice Dumas 2008-04-09 16:01:44 EDT
I asked to have it pushed to stable before knowing about this issue.
Comment 4 Patrice Dumas 2008-04-10 04:29:03 EDT
In F9, even with libklashpart, it doesn't seems to work for me. But maybe it is
because konqueror is kde4 konqueror. Therefore, could you please try the scratch
build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=560705

and report back if it works for you on F-8?
Comment 5 Oliver Henshaw 2008-04-10 06:42:26 EDT
Yep, the scratch build works here on F8.
Comment 6 Fedora Update System 2008-04-10 08:08:56 EDT
gnash-0.8.2-3.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-04-10 08:09:26 EDT
gnash-0.8.2-3.fc7 has been submitted as an update for Fedora 7
Comment 8 Fedora Update System 2008-04-16 23:51:30 EDT
gnash-0.8.2-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnash'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3092
Comment 9 Fedora Update System 2008-04-22 18:36:56 EDT
gnash-0.8.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-04-22 18:43:45 EDT
gnash-0.8.2-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.