Bug 441604 - /etc/init.d/nfslock carries obsolete code for Linux 2.2
/etc/init.d/nfslock carries obsolete code for Linux 2.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 18:58 EDT by Michal Schmidt
Modified: 2008-11-24 12:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 12:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
nfslock initscript cleanup patch (2.33 KB, patch)
2008-04-08 18:58 EDT, Michal Schmidt
no flags Details | Diff

  None (edit)
Description Michal Schmidt 2008-04-08 18:58:45 EDT
Description of problem:
The nfslock initscript has code to support userland lockd with Linux kernels
2.2.18 and older. The code is useless because no supported distribution today
can run with Linux 2.2. It should be removed.

Version-Release number of selected component (if applicable):
nfs-utils-1.1.2-1.fc9.x86_64

Patch attached.
Comment 1 Michal Schmidt 2008-04-08 18:58:45 EDT
Created attachment 301724 [details]
nfslock initscript cleanup patch
Comment 2 Steve Dickson 2008-04-25 11:41:27 EDT
Fixed in nfs-utils-1.1.2-3
Comment 3 Bug Zapper 2008-05-14 05:09:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.