Bug 441667 - Intel 965 screen dark on resume
Intel 965 screen dark on resume
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 08:36 EDT by Niall Sheridan
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 07:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Niall Sheridan 2008-04-09 08:36:54 EDT
Description of problem:

When I wake my laptop from suspend, the screen is always completely dark. I can
blindly reboot the machine, and if I squint and hold the machine up to the light
I can make out a gnome-screensaver password dialog.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Put laptop into suspend
2. Wake up
3. Darkness
  
Actual results:
An almost impossible to see screen that won't respond to brightness controls.

Expected results:
A screen I can see things on.

Additional info:
I've found that the following makes my laptop behave when putting it to
sleep/waking it up:

[root@particle ~]# cat /etc/pm/config.d/config
DISPLAY_QUIRK_S3_BIOS="true"
Comment 1 Till Maas 2008-04-09 12:02:21 EDT
The information which quirks should be applied is stored in hal-info.

Please follow:
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html
to submit your findings upstream, but please post before this the output of
lshal | egrep
"(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"

And what is also important is: How do you put your machine into suspend? (Do you
call pm-suspend directly, use gnome-power-manager or something similiar?)
Comment 2 Niall Sheridan 2008-04-09 15:11:45 EDT
I tried using pm-suspend and g-p-m and observed identical behaviour with both.
'pm-suspend --quirk-s3-bios' comes out of sleep just fine, while 'pm-suspend'
does not.

$ lshal | egrep \
"(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"
  system.firmware.version = '7NET25WW (1.06 )'  (string)
  system.hardware.product = '7668CTO'  (string)
  system.hardware.vendor = 'LENOVO'  (string)
  system.hardware.version = 'ThinkPad X61s'  (string)

So it looks like
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-lenovo.fdi is
missing '7668' from the list of keys to match in system.hardware.product. In
fact, a glance through the hal-info gitweb shows that this was added a few days ago:
http://gitweb.freedesktop.org/?p=hal-info.git;a=blobdiff;h=0da863d5ca3c815a5f5cbaab033926cac2200fbd;hp=064c0d9ef4ca5bbcd6d2765682d57c840bfc7ac5;hb=71c4a54fd1c4b16873ae560f31f6e1bf6a8de74f;f=fdi/information/10freedesktop/20-video-quirk-pm-lenovo.fdi

Testing locally, adding 7668 to 20-video-quirk-pm-lenovo.fdi makes both g-p-m
and pm-suspend behave exactly as I'd like them to. Any chance of merging
upstream's additions for F9?
Comment 3 Bug Zapper 2008-05-14 05:11:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Niall Sheridan 2008-05-30 02:15:47 EDT
This was fixed for me by hal-info-20080508-1.fc9

Note You need to log in before you can comment on or make changes to this bug.