Bug 441671 - VESA driver crashes on PowerBook with ATI RV350
VESA driver crashes on PowerBook with ATI RV350
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
rawhide
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 09:00 EDT by Frank Arnold
Modified: 2008-04-09 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 13:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (7.86 KB, text/plain)
2008-04-09 09:00 EDT, Frank Arnold
no flags Details
/etc/X11/xorg.conf (385 bytes, text/plain)
2008-04-09 09:02 EDT, Frank Arnold
no flags Details

  None (edit)
Description Frank Arnold 2008-04-09 09:00:55 EDT
Description of problem:
Trying to start X with the VESA driver on a PowerBook results in an abort and a
logged backtrace. Not sure if this ever worked, or is supposed to work. The
Radeon driver is broken on this hardware, too. Thats why I tried it.

Hardware:
PowerBook5,6
ATI Mobility Radeon 9700 (RV350)

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-1.3.0-14.20080404.fc9
Comment 1 Frank Arnold 2008-04-09 09:00:55 EDT
Created attachment 301796 [details]
/var/log/Xorg.0.log
Comment 2 Frank Arnold 2008-04-09 09:02:23 EDT
Created attachment 301797 [details]
/etc/X11/xorg.conf
Comment 3 Adam Jackson 2008-04-09 13:20:43 EDT
The vesa driver is not expected to work on powerbooks, no.  We include the vesa
driver for powerpc machines because it should work on cards with an x86 BIOS on
them, but the built-in graphics on mac laptops obviously don't belong to that set.

How does the radeon driver fail?
Comment 4 Frank Arnold 2008-04-09 13:41:58 EDT
(In reply to comment #3)
> The vesa driver is not expected to work on powerbooks, no.

Ok, closing then. A more graceful exit would be nice, though... ;)

> How does the radeon driver fail?

It's bug 431872. But it seems to have mysteriously vanished, like every time I'm
running into an error on X...


Note You need to log in before you can comment on or make changes to this bug.