Bug 441682 - network config bug
network config bug
Status: CLOSED DUPLICATE of bug 426766
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 10:07 EDT by Giuseppe Zicchinolfi
Modified: 2008-04-10 03:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 10:39:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug of application (2.29 KB, application/softgrid-txt)
2008-04-09 10:07 EDT, Giuseppe Zicchinolfi
no flags Details

  None (edit)
Description Giuseppe Zicchinolfi 2008-04-09 10:07:42 EDT
Description of problem: TB31c4e20f

After Yum Update and normal reboot of machine when it's restart ,network menu
is not available for this motivation:

Component: system-config-network
Version: 1.4.7
Summary: TB31c4e20f NCHardwareList.py:798:load:ValueError: invalid literal for 
int() with base 10: 'None'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 
277, in load
    self.loadDevices()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 
285, in loadDevices
    devicelist = getDeviceList()
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 
306, in getDeviceList
    __DVList.load()
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 74, 
in load
    hwlist = NCHardwareList.getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 
890, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 
798, in load
    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])
ValueError: invalid literal for int() with base 10: 'None'

Local variables in innermost frame:
hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0x9c4f2cc>
i: 2
self: HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=b44
HardwareList.Ethernet.eth0.Description=Broadcom Corporation BCM4401-B0 100Base-
TX
HardwareList.Wireless.eth1.Status=ok
HardwareList.Wireless.eth1.Name=eth1
HardwareList.Wireless.eth1.Type=Wireless
HardwareList.Wireless.eth1.Card.ModuleName=ipw2100
HardwareList.Wireless.eth1.Description=Intel Corporation PRO/Wireless LAN 2100 
3B Mini PCI Adapter
HardwareList.Modem.Modem0.Status=configured
HardwareList.Modem.Modem0.Name=Modem0
HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem
HardwareList.Modem.Modem0.Type=Modem
HardwareList.Modem.Modem0.Description=Generic Modem

isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x9c6be0c>
hw: Hardware.Status=configured
Hardware.Name=Modem0
Hardware.Modem.DeviceName=/dev/modem
Hardware.Type=Modem
Hardware.Description=Generic Modem

dev: Modem0
wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0x9f3178c>

Version-Release number of selected component (if applicable):

Component: system-config-network
Version: 1.4.7

How reproducible:

every time

Steps to Reproduce:

click on network icon

  
Actual results:

network menu is not available 


Expected results:


Additional info:
Comment 1 Giuseppe Zicchinolfi 2008-04-09 10:07:42 EDT
Created attachment 301810 [details]
bug of application
Comment 2 Jiri Moskovcak 2008-04-09 10:39:26 EDT

*** This bug has been marked as a duplicate of 426766 ***
Comment 3 Giuseppe Zicchinolfi 2008-04-10 03:05:38 EDT
Problem solved , modify parameters in /etc/wvdial.conf as indicated in 
duplicate bugs report :

[Modem0]
Baud = 460800 
SetVolume = 5
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM1LNone 
FlowControl = None

Comment 4 Giuseppe Zicchinolfi 2008-04-10 03:07:03 EDT
thank you very much for support .

Note You need to log in before you can comment on or make changes to this bug.