Bug 441726 - traceback when erasing packages
traceback when erasing packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-presto (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 13:37 EDT by Pekka Pietikäinen
Modified: 2008-08-06 08:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 08:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2008-04-09 13:37:37 EDT
Description of problem:

[root@it-pc37 ~]# yum remove emacs
Loaded plugins: fastestmirror, presto, refresh-packagekit, refresh-updatesd
Setting up Remove Process
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for dribble-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for rawhide
Loading mirror speeds from cached hostfile
 * livna-development: ftp-stud.fht-esslingen.de
 * dribble-development: dribble.org.uk
 * adobe-linux-i386: linuxdownload.adobe.com
 * rawhide: ftp.uni-erlangen.de
Resolving Dependencies
--> Running transaction check
---> Package emacs.i386 0:22.1.50-4.fc9 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 emacs                   i386       22.1.50-4.fc9    installed         5.4 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing   : emacs                        ######################### [1/1] 
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 188, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 430, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 781, in
runTransaction
    self.plugins.run('posttrans')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 175, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 468, in posttrans_hook
    (complete_download_size == actual_download_size):
NameError: global name 'actual_download_size' is not defined
[root@it-pc37 ~]# rpm -q yum-presto
yum-presto-0.4.4-1.fc9.noarch
Comment 1 Jonathan Dieter 2008-04-10 00:19:04 EDT
Can you test
http://www.lesbg.com/jdieter/presto/yum-presto-0.4.5-1.les8.noarch.rpm ?  It
should fix the problem.
Comment 2 Pekka Pietikäinen 2008-04-10 03:09:05 EDT
Fix confirmed.
Comment 3 Fedora Update System 2008-04-10 04:13:39 EDT
yum-presto-0.4.5-1.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-16 23:51:09 EDT
yum-presto-0.4.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-presto'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3089
Comment 5 Fedora Update System 2008-04-29 16:50:34 EDT
yum-presto-0.4.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Bug Zapper 2008-05-14 05:12:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jan Hutař 2008-08-06 08:08:58 EDT
Hello,
I can not reproduce on the F9. Could you please test with new packages?

# yum remove rsh
Loaded plugins: allowdowngrade, changelog, downloadonly, merge-conf, presto,
              : protectbase, refresh-packagekit, refresh-updatesd, tmprepo,
              : upgrade-helper, verify
Setting up Remove Process
Setting up and reading Presto delta metadata
No Presto metadata available for fedora
...
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package rsh.x86_64 0:0.17-50.fc9 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 rsh                     x86_64     0.17-50.fc9      installed          73 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : rsh                                               [1/1] 
Unable to look at what's on dbus

Removed: rsh.x86_64 0:0.17-50.fc9
Complete!
# rpm -q yum yum-presto
yum-3.2.17-2.fc9.noarch
yum-presto-0.4.5-1.fc9.noarch
Comment 8 Pekka Pietikäinen 2008-08-06 08:21:50 EDT
Comment #2 From  Pekka Pietikäinen   2008-04-10 03:09:05 EDT   (-) [reply] -------
Fix confirmed.

:) 

-> closing.

Note You need to log in before you can comment on or make changes to this bug.