Bug 441738 - Software Updater abnormally terminated when launched
Software Updater abnormally terminated when launched
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.3
i386 Linux
low Severity urgent
: rc
: ---
Assigned To: Pradeep Kilambi
:
: 481053 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 14:32 EDT by Mark Knox
Modified: 2009-09-02 07:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
the software updater (pup) did not parse OpenSSL error messages correctly. Therefore, when it encountered an invalid or missing SSL certificate, the updater would crash. The parsing code is now corrected, so invalid or missing SSL certificate will not result in a crash.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:22:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dump of Crash after attempting to run Software Updater (2.75 KB, application/octet-stream)
2008-04-09 14:32 EDT, Mark Knox
no flags Details
Updated error report from Software Updater (2.75 KB, application/octet-stream)
2008-06-03 13:21 EDT, Mark Knox
no flags Details

  None (edit)
Description Mark Knox 2008-04-09 14:32:09 EDT
Error Dump attempting to run Software Updator
Comment 1 Mark Knox 2008-04-09 14:32:09 EDT
Created attachment 301873 [details]
Dump of Crash after attempting to run Software Updater
Comment 2 John Matthews 2008-05-27 15:09:40 EDT
It looks like an OpenSSL exception is being thrown, but we aren't parsing it
correctly.  

If you would apply the below change and include the new output it would aid us
in understanding what the problem is.

/usr/share/rhn/up2date_client

Index: rhnserver.py
===================================================================
--- rhnserver.py        (revision 172967)
+++ rhnserver.py        (working copy)
@@ -58,7 +58,7 @@
             error = error.strip("[()]")
             pieces = error.split(',')
             message = ""
-            if len(pieces) >= 2:
+            if len(pieces) > 2:
                 message = pieces[2].strip(" '")
             if message == 'certificate verify failed':
                 raise up2dateErrors.SSLCertificateVerifyFailedError()
Comment 3 Mark Knox 2008-06-03 13:21:32 EDT
Created attachment 308265 [details]
Updated error report from Software Updater
Comment 8 Pradeep Kilambi 2009-06-10 08:52:26 EDT
*** Bug 481053 has been marked as a duplicate of this bug. ***
Comment 13 Ruediger Landmann 2009-08-27 21:49:15 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
the software updater (pup) did not parse OpenSSL error messages 
correctly. Therefore, when it encountered an invalid or missing SSL 
certificate, the updater would crash. The parsing code is now corrected, 
so invalid or missing SSL certificate will not result in a crash.
Comment 14 errata-xmlrpc 2009-09-02 07:22:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1355.html

Note You need to log in before you can comment on or make changes to this bug.