Bug 441761 - Cannot login to kde session via kdm
Summary: Cannot login to kde session via kdm
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-09 21:06 UTC by Orion Poplawski
Modified: 2008-04-11 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 16:32:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2008-04-09 21:06:24 UTC
Description of problem:

With today's rawhide, I cannot log in.  Denials:

type=1400 audit(1207762680.007:9): avc:  denied  { create } for  pid=3368
comm="kdm_greet" name="kdm" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:var_lib_t:s0 tclass=dir
type=1400 audit(1207762680.379:10): avc:  denied  { execute_no_trans } for 
pid=6013 comm="kdm" path="/etc/kde/kdm/Xsession" dev=sda3 ino=119208
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:xsession_exec_t:s0 tclass=file
type=1400 audit(1207762680.477:11): avc:  denied  { ioctl } for  pid=6013
comm="sh" path="/etc/kde/kdm/Xsession" dev=sda3 ino=119208
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:xsession_exec_t:s0 tclass=file
type=1400 audit(1207762680.617:12): avc:  denied  { write } for  pid=6060
comm="dbus-daemon" path="/export/home/orion/.xsession-errors" dev=sda7
ino=1238552 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
tcontext=system_u:object_r:user_home_t:s0 tclass=file
type=1400 audit(1207762680.842:13): avc:  denied  { execute } for  pid=6114
comm="bash" name="rpm" dev=sda3 ino=278614
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:rpm_exec_t:s0 tclass=file
type=1400 audit(1207762680.842:14): avc:  denied  { getattr } for  pid=6114
comm="bash" path="/bin/rpm" dev=sda3 ino=278614
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:rpm_exec_t:s0 tclass=file
type=1400 audit(1207762680.842:15): avc:  denied  { getattr } for  pid=6114
comm="bash" path="/bin/rpm" dev=sda3 ino=278614
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:rpm_exec_t:s0 tclass=file
type=1400 audit(1207762680.879:16): avc:  denied  { execute } for  pid=6013
comm="bash" name="bash" dev=sda3 ino=109717
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:usr_t:s0 tclass=file
type=1400 audit(1207762681.603:17): avc:  denied  { getattr } for  pid=6013
comm="startkde" path="/usr/bin/gpg-agent" dev=sda3 ino=346284
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:gpg_agent_exec_t:s0 tclass=file
type=1400 audit(1207762681.898:18): avc:  denied  { write } for  pid=6192
comm="polkit-read-aut" path="/export/home/orion/.xsession-errors" dev=sda7
ino=1238552 scontext=system_u:system_r:polkit_auth_t:s0-s0:c0.c1023
tcontext=system_u:object_r:user_home_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-3.3.1-31.fc9.noarch

Comment 1 Rex Dieter 2008-04-11 14:45:42 UTC
fwiw, I can't reproduce this (I can login).

Comment 2 Orion Poplawski 2008-04-11 16:32:41 UTC
Works for me as well with selinux-policy-3.3.1-33.fc9.noarch.


Note You need to log in before you can comment on or make changes to this bug.