Bug 441790 - [scim-python-xingma] Certain characters are not found by CangJie 5 IME.
[scim-python-xingma] Certain characters are not found by CangJie 5 IME.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scim-python (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 01:42 EDT by Caius Chance
Modified: 2008-07-08 10:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 10:40:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2008-04-10 01:42:47 EDT
Description of problem:
There are some characters were not found in CangJie 5 when scim-python-xingma
package is installed. This bug is not reproducible when scim-tables and
scim-tables-chinese is installed.

Version-Release number of selected component (if applicable):
$ rpm -qa |grep scim
scim-anthy-1.2.4-4.fc9.i386
scim-hangul-0.3.2-4.fc9.i386
scim-python-0.1.10-3.fc9.i386
scim-python-pinyin-0.1.10-3.fc9.i386
scim-python-0.1.10-2.fc9.i386
scim-fcitx-3.1.1-9.fc9.i386
scim-skk-0.5.2-8.fc6.i386
scim-lang-japanese-1.4.7-21.fc9.i386
scim-python-xingma-cangjie-0.1.10-3.fc9.i386
scim-gtk-1.4.7-21.fc9.i386
scim-devel-1.4.7-21.fc9.i386
scim-bridge-gtk-0.4.15-5.fc9.i386
scim-chewing-0.3.1-15.fc9.i386
scim-tables-0.5.8-1.fc9.i386
scim-sinhala-0.2.0-6.fc9.i386
scim-libs-1.4.7-21.fc9.i386
scim-lang-korean-1.4.7-21.fc9.i386
scim-python-pinyin-0.1.10-2.fc9.i386
scim-1.4.7-21.fc9.i386
scim-lang-oriya-1.4.7-21.fc9.i386
scim-bridge-0.4.15-5.fc9.i386
scim-python-xingma-0.1.10-3.fc9.i386
scim-bridge-qt-0.4.15-5.fc9.i386
scim-array-0.0.4-0.fc9.i386
scim-pinyin-0.5.91-25.fc9.i386
scim-m17n-0.2.2-3.fc9.i386
scim-tables-chinese-0.5.8-1.fc9.i386
scim-lang-chinese-1.4.7-21.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Install scim, scim-tables, scim-tables-chinese, scim-python,
scim-python-xingma, scim-python-xingma-cangjie and relevant packages (or just
yum groupinstall chinese-support).
2. Start im-chooser and pick SCIM as default, logout and back.
3. Start gnome desktop.
4. Start gnome-terminal.
5. Start gedit with gnome-terminal.
6. Turn on scim with ctrl+space.
7. Change to ChangJie 5.
8. On gedit, press the following keys: 's' 'q' 'n' 'l'.
9. See results.
  
Actual results:
Chars '尸撱' are shown.

Expected results:
Char '那' is shown.

Additional info:
Uninstall scim-python-xingma-* (may be just scim-python-xingma and
scim-python-xingma-cangjie) the problem is gone.

There is some error messages when committing too:

Unknown message: Traceback (most recent call last):
Unknown message:   File "/usr/share/scim-python/engine/XingMa/XMSQLiteDB.py",
line 543, in parse_phrase
Unknown message:     gcm = self.get_gcm_id (phrase[zi])
Unknown message:   File "/usr/share/scim-python/engine/XingMa/XMSQLiteDB.py",
line 517, in get_gcm_id
Unknown message:     return self.db.execute(sqlstr,(zi,)).fetchall()[0]
Unknown message: IndexError: list index out of range
Unknown message: Traceback (most recent call last):
Unknown message:   File "/usr/share/scim-python/engine/XingMa/XingMa.py", line
910, in process_key_event
Unknown message:     result = self._process_key_event (key)
Unknown message:   File "/usr/share/scim-python/engine/XingMa/XingMa.py", line
940, in _process_key_event
Unknown message:     return self._xingma_mode_process_key_event (key)
Unknown message:   File "/usr/share/scim-python/engine/XingMa/XingMa.py", line
1114, in _xingma_mode_process_key_event
Unknown message:     self.db.check_phrase (sp_res[1])
Unknown message:   File "/usr/share/scim-python/engine/XingMa/XMSQLiteDB.py",
line 564, in check_phrase
Unknown message:     _len = len (wordattr) -3
Unknown message: TypeError: object of type 'NoneType' has no len()
Comment 1 Peng Huang 2008-04-16 23:28:53 EDT
Fixed in scim-python-0_1_11-1_fc9.
Comment 2 Bug Zapper 2008-05-14 05:13:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jens Petersen 2008-07-08 02:35:52 EDT
Caius, is this better for you now?
Comment 4 Caius Chance 2008-07-08 10:25:32 EDT
This is resolved. Thank you very much for your excellent commitment, phuang!
Please kindly close this bug as resolved.

There would be a feature request of wildcard (*), but it will filed as a new bug
report.

Note You need to log in before you can comment on or make changes to this bug.