Bug 44182 - xdvi mishandling font location and generation
Summary: xdvi mishandling font location and generation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-12 00:16 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-14 13:50:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DVI file which causes font errors from xdvi each time it is viewed (220 bytes, application/octet-stream)
2001-06-12 10:42 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2001-06-12 00:16:44 UTC
Every time I run xdvi on my DVI file, I see:

kpathsea: Running mktexpk --mfmode ljfour --bdpi 300 --mag 1+0/300 --dpi
300 cmti12
mktexpk: Mismatched mode ljfour and resolution 300; ignoring mode.
mktexpk: /var/lib/texmf/pk/cx/public/cm/cmti12.300pk already exists.
kpathsea: Running mktexpk --mfmode ljfour --bdpi 300 --mag 1+0/300 --dpi
300 cmr12
mktexpk: Mismatched mode ljfour and resolution 300; ignoring mode.
mktexpk: /var/lib/texmf/pk/cx/public/cm/cmr12.300pk already exists.

Dvips does not appear to have the same problem locating the relevant fonts.

I've got tetex-xdvi-1.0.7-19, and the latest rawhide version of all the
other tetex packages as well.

Comment 1 Jonathan Kamens 2001-06-12 00:20:45 UTC
This problem goes away if I revert to tetex-xdvi-1.0.7-15.


Comment 2 Tim Waugh 2001-06-12 08:54:17 UTC
With tetex-xdvi-1.0.7-15 I see the same output when I run the command:

mktexpk --mfmode ljfour --bdpi 300 --mag 1+0/300 --dpi 300 cmti12

twice (once to generate the font, and once again so it says 'already exists').

Please provide a dvi file that xdvi shows the problem with.

Thanks.


Comment 3 Jonathan Kamens 2001-06-12 10:42:03 UTC
Of course you get the same error when you run that command by hand; the bug is
that xdvi is running the font generation command!

In any case, as requested, I will attach a DVI file which demonstrates this
problem.


Comment 4 Jonathan Kamens 2001-06-12 10:42:38 UTC
Created attachment 20842 [details]
DVI file which causes font errors from xdvi each time it is viewed

Comment 5 Tim Waugh 2001-06-12 10:51:49 UTC
I see what you're saying: that xdvi shouldn't call mktexpk at all, since the 
font already exists.

If you change 'ljour' to 'cx' in /usr/share/texmf/xdvi/XDvi, does the problem 
go away?


Comment 6 Jonathan Kamens 2001-06-12 11:38:21 UTC
Yes.


Comment 7 Tim Waugh 2001-06-20 10:40:28 UTC
Fixed in tetex-1.0.7-22.



Note You need to log in before you can comment on or make changes to this bug.