Bug 44185 - rescue mode does not work with serial console
rescue mode does not work with serial console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-11 20:33 EDT by Sean Dilda
Modified: 2007-04-18 12:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 10:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Dilda 2001-06-11 20:33:39 EDT
If you try to boot into rescue mode with a serial console, /sbin/loader
will startup and ask you to choose a language.  No matter what language you
chose, it will always ask you to chose your language again.  It never moves
beyond this screen.
This was tested on an alpha.
Comment 1 Bill Nottingham 2001-06-21 14:48:44 EDT
This may have something to do with #45284. ewt; you might need to change
this in installinit.
Comment 2 Michael Fulbright 2001-08-07 17:06:21 EDT
Brent please work with Bill on this - I have a serial cable if you need.
Comment 3 Brent Fox 2001-08-24 18:10:16 EDT
I don't see this on x86 hardware.  What kinds of Alphas do you have?
Comment 4 Peter Bowen 2001-08-24 18:19:16 EDT
I found the bug on a CS20.  I think it is similar to the DS20L that Bryce (Phil
Copeland) has.
Comment 5 Sean Dilda 2001-08-24 18:23:25 EDT
This was found on a CS20 (http://www.apinetworks.com/products/cs20.shtml).
Comment 6 Peter Bowen 2001-08-25 15:44:00 EDT
On unique thing about the CS20, that could be causing the problem, is that is
has no video card, and no keyboard or mouse ports (neither PS/2 nor USB), and 
no keyboard controller.
Comment 7 Brent Fox 2001-08-27 11:10:17 EDT
We don't currently support the CS20, and I'm not aware of any plans to support
it in the future.
Comment 8 Peter Bowen 2001-10-23 10:42:00 EDT
This bug actually is not dependent on alpha, just on using a serial console in
rescue mode.  The problem is that chooseKeyboard, in loader/lang.c returns
LOADER_NOOP if FL_SERIAL is set.  This works fine during normal operation of the
installer, but in rescue mode, chooseKeyboard is called in this bit of code in
loader/loader.c:

            do {
                chooseLanguage(&lang, flags);
                defaultLang = 0;
                rc = chooseKeyboard (&keymap, &kbdtype, flags);
            } while (rc);

The problem is the this is an endless loop, as rc is always non-zero.  In 7.2,
this has been fixed by changing the last line to read:

            } while ((rc) && (rc != LOADER_NOOP));

So this actually was a bug, and it looks like some one already caught it.
Comment 9 Brent Fox 2001-10-24 15:37:11 EDT
I guess I didn't see it on x86 hardware originally because I was using the 7.2
beta trees...  Anyway, I'll close this a 'CurrentRelease' since it appears to be
fixed in 7.2.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.