Bug 441893 - hyperlinks in OOo help don't work
hyperlinks in OOo help don't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 439050
  Show dependency treegraph
 
Reported: 2008-04-10 13:36 EDT by Joe Smith
Modified: 2008-04-22 09:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 09:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 87490 None None None Never

  None (edit)
Description Joe Smith 2008-04-10 13:36:16 EDT
Description of problem:
Clicking a hyperlink in the OOo online help should select a new help page.
Instead, it erroneously launches a browser with an unrecognized URL.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.4.0-12.5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open OOo Writer (or any component app)
2. Help > OO.org Help
3. Click any hyperlink on the right-hand (help text) panel, e.g. "OpenOffice.org
Writer Features"
  
Actual results:
A web browser error dialog appears with this text:
Firefox doesn't know how to open this address, because the protocol
(vnd.sun.star.help) isn't associated with any program.

Expected results:
A new page in the OOo online help should appear.

Additional info:
Note that when the user's desktop uses "focus follows mouse" the error dialog is
hidden behind the OOo help window, so that it may appear that nothing happens
when the help links are activated.
Comment 1 Caolan McNamara 2008-04-11 03:33:24 EDT
Hmm, I wonder did I break this with the protocol fix

Note You need to log in before you can comment on or make changes to this bug.