Bug 441893 - hyperlinks in OOo help don't work
Summary: hyperlinks in OOo help don't work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 439050
TreeView+ depends on / blocked
 
Reported: 2008-04-10 17:36 UTC by Joe Smith
Modified: 2008-04-22 13:04 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-04-22 13:04:51 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 87490 None None None Never

Description Joe Smith 2008-04-10 17:36:16 UTC
Description of problem:
Clicking a hyperlink in the OOo online help should select a new help page.
Instead, it erroneously launches a browser with an unrecognized URL.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.4.0-12.5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open OOo Writer (or any component app)
2. Help > OO.org Help
3. Click any hyperlink on the right-hand (help text) panel, e.g. "OpenOffice.org
Writer Features"
  
Actual results:
A web browser error dialog appears with this text:
Firefox doesn't know how to open this address, because the protocol
(vnd.sun.star.help) isn't associated with any program.

Expected results:
A new page in the OOo online help should appear.

Additional info:
Note that when the user's desktop uses "focus follows mouse" the error dialog is
hidden behind the OOo help window, so that it may appear that nothing happens
when the help links are activated.

Comment 1 Caolan McNamara 2008-04-11 07:33:24 UTC
Hmm, I wonder did I break this with the protocol fix


Note You need to log in before you can comment on or make changes to this bug.