This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 441941 - installation error: error initializing udevd socket
installation error: error initializing udevd socket
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 15:52 EDT by Sebastian Vahl
Modified: 2008-04-23 06:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 06:17:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-04-10 15:52:28 EDT
Description of problem:
When I create current live images I get the following error during the 
installation of the packages:

Installing: udev  ##################### [507/787]error initializing udevd 
socket


Version-Release number of selected component (if applicable):
udev-120-2.fc9.i386

How reproducible:
ever

Steps to Reproduce:
1. create a live image
2. watch output of livecd-creator
3.
  
Actual results:
error

Expected results:
no error

Additional info:
I'm not able to reproduce this in a normal installation with "yum reinstall 
udev".
Comment 1 Warren Togami 2008-04-10 22:47:24 EDT
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
According to the scriptlet documentation, %post $1 should equal 1 during
installation and 2 during upgrade.  I also noticed that there is a logic bug, it
shouldn't be using chkconfig --del during %post.  I'm guessing this was a copy &
paste problem?

%preun
if [ "$1" = 0 -a -f %{_initrddir}/udev ]; then
Furthermore the %preun seems to make no sense.  When will this ever be true?  In
any case it appears to be harmless at least.  

The following patch should fix this and result in proper behavior.  Some review
please?

--- udev.spec	5 Apr 2008 16:29:16 -0000	1.242
+++ udev.spec	11 Apr 2008 02:43:47 -0000
@@ -269,19 +269,14 @@ fi
 exit 0
 
 %post
-if [ "$1" -ge "1" -a -x /sbin/pidof ]; then
+if [ "$1" -gt "1" -a -x /sbin/pidof ]; then
 	pid=$(/sbin/pidof -c udevd)
 	if [ -n "$pid" ]; then
 		kill $pid
+	        /sbin/udevd -d
 	fi
 fi
 
-
-if [ "$1" -ge "1" ]; then
-	/sbin/udevd -d
-	/sbin/chkconfig --del udev-post >/dev/null 2>&1 || :
-fi
-
 /sbin/chkconfig --add udev-post
 exit 0
 
Comment 2 Sebastian Vahl 2008-04-11 05:20:25 EDT
I've grabbed you patch, created a local RPM and build a new live image with it.
The installation of udev is now silent. But I haven't had the time yes to do
some further tests (not even start the image).

Note You need to log in before you can comment on or make changes to this bug.