Bug 441992 - catalog will not send the correct information after I(reviewer) check the "Make certification public" of bug #441211
catalog will not send the correct information after I(reviewer) check the "Ma...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: web site (Show other bugs)
2
All Linux
high Severity high
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 23:48 EDT by QinXie
Modified: 2008-06-23 03:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: (2.18rh) 2008/05/23 push
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 03:33:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch to fix the bug (1.41 KB, patch)
2008-04-11 06:43 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description QinXie 2008-04-10 23:48:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Just check the "Make certification public" box, and then submit you request. And
check whehter you get the one email to tell you hwcer-edit is removed.

Steps to Reproduce:
1. set me to be the reviewer of #441211;
2. finish the review;
3. close the cert as certified;
4. check the "make certification public" box;
5. I noticed I am in the send to list;


  
Actual results:
check my mail box, no info about hwcert-edit is mentioned.

Expected results:
check my mail box, I should get one mail to inform me hwcert-edit is removed.

Additional info:
Comment 1 XINSUN 2008-04-11 06:38:26 EDT
This bug is caused by "the catalog saved a no useful timestamp value
:"0000-00-00 00:00:00" into the bug_when column in the bugs_activity tables".
Sothe BugMail module which send a mail to remind what changes has been made in
the cert can not select and mail out "the bug activity" or "bug modification"
items whose timestamp value == "0000-00-00 00:00:00".
Comment 2 XINSUN 2008-04-11 06:43:13 EDT
Created attachment 302101 [details]
The patch to fix the bug
Comment 3 Rob Landry 2008-05-13 12:49:38 EDT
xisun, please take a look for other uses of now() in the code; seems like this
is a side effect from switching db's earlier.  Perhaps that should be another bug?
Comment 4 XINSUN 2008-05-14 09:18:16 EDT
Have token a look for the other uses of now() in the code, and opened a new
bug446334

Patch has been summited into cvs.

Note You need to log in before you can comment on or make changes to this bug.