Bug 442002 - system crashes after suspend to ram with 4G memory
system crashes after suspend to ram with 4G memory
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Lenny Szubowicz
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 02:47 EDT by henry su
Modified: 2013-08-15 09:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 09:06:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description henry su 2008-04-11 02:47:55 EDT
Description of problem:
After resume from S3, the file system is mounted as readonly, I cannot execute
most commands such as touch,mkdir...
Press the reset button to reboot the system,the system crashed,and I cannot
mount this partition from other linux OSes, so I have to reinstall the operating
system.  

Version-Release number of selected component (if applicable):

How reproducible:always

Steps to Reproduce:
1. install RHEL5U2 beta x86_64 with 4G memory
2. try the sleep button or "pm-suspend --quirk-s3-bios"
3. press power button to resume from S3, 
  
Actual results:
The file system is mounted as readonly after resume from S3, the system crashed
after press reset button.

Expected results:
all funtions should work well after resume from S3.

Additional info:
1.Kernel version: 2.6.18-84.e15
2.The sata hard disk should be ok, I have tested on three defferent Sata hard
disks(two seagate disks,on hitachi disk)

dmesg after resume from S3:
------------------------------------
init special inode bogus 1 mode(0)
attemp to access beyong end of device
sda5: rw=0 want=2607391624 limit=40965687
Ext-fs error (device sda5):ext3 xattr block get inode 3133449 bad block 3146756
Aborting journal on device sda5
ext3 abort called
Ext3-fs error (device sda5): ext3 journal start sb: detected aborted journal
Remount the filesystem readonly
inode doinit with dentry: get xattr returned 5 for dev=sda5 ino=3133449
Ext-fs error (device sda5):ext3 xattr block get inode 3133442 bad block 3146755
inode doinit with dentry: get xattr returned 5 for dev=sda5 ino=3133442
Ext-fs error (device sda5):ext3 xattr block get inode 3133443 bad block 3146755
inode doinit with dentry: get xattr returned 5 for dev=sda5 ino=3133443
Comment 1 Matthew Garrett 2010-07-13 09:58:11 EDT
Hi Henry,

Is this still a problem with current updates? There's been various work done on supporting S3 with 4GB since 5.2.
Comment 2 Lenny Szubowicz 2013-01-29 14:33:00 EST
Hi Henry,

I've recently inherited this open, but quite old, problem report. Is this problem still reproducible with RHEL 5.9?
Comment 3 Lenny Szubowicz 2013-08-15 09:06:59 EDT
Given how long this problem has gone unresolved, it's relatively low severity, and the lifecycle stage that RHEL 5 is currently in, the problem reported will not be fixed in RHEL 5.

                                   -Lenny.

Note You need to log in before you can comment on or make changes to this bug.