This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442024 - tftpd rewrite functionality needs patched.
tftpd rewrite functionality needs patched.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tftp (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Martin Nagy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 07:37 EDT by strife
Modified: 2016-07-26 19:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: tftp-0.39-3.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 09:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description strife 2008-04-11 07:37:02 EDT
Description of problem:

Using rewrite in tftpd server is severely broken.

Version-Release number of selected component (if applicable):

tftp-server.i386                         0.39-2

How reproducible:

every time

Steps to Reproduce:
1. create a file in /etc called tftpd with rg \\ /
2. edit /etc/xinetd.d/tftp
server_args             = -s /tftpboot -m /etc/tftpd
  
Actual results:

in.tftpd[18134]: r rules cannot be inverted, line 1:  \\ /

Expected results:

converting \ in requested paths to /

Additional info:

None at this time.
Comment 1 Martin Nagy 2008-04-15 05:25:33 EDT
This bug is a duplicate of a private bug. We are currently working on this and
an errata fixing this should be out shortly. When it is, I'm going to close this
as CURRENTRELEASE.
Comment 2 Martin Nagy 2008-04-23 09:52:36 EDT
This bug was addressed in RHBA-2008-0160, this bug is now fixed in tftp-0.39-3.el4
Thus closing this bug with the resolution of CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.