This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442073 - RFE: add an option to cman init for LEAVE option
RFE: add an option to cman init for LEAVE option
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Ryan O'Hara
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 11:47 EDT by Thorsten Scherf
Modified: 2009-04-16 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 20:13:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2008-04-11 11:47:15 EDT
Description of problem:
would be great to have an option for the cman init script which allows to call
"cman_tool leave remove" to recalculate quorum when cman is stopped. looks like
this is the only clean option to call "cman_tool leave remove". when you call it
manually it doesn't work since a lot of processes rely on cman (fenced, ccsd,
...), actually you have to kill them manually in order to call "cman_tool leave
remove".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thorsten Scherf 2008-04-11 11:50:46 EDT
add an option for LEAVE REMOVE of course :)
Comment 2 Christine Caulfield 2008-04-14 05:33:30 EDT
I think this would be a good thing to have for another reason, cman_tool leave
remove doesn't seem to be tested at the moment and this might help that,
particularly as it seems to be broken in alternate releases at the moment.
Comment 4 RHEL Product and Program Management 2008-07-07 11:25:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Ryan O'Hara 2008-07-28 15:46:11 EDT
It appears that the default behavior in RHEL5 is to call 'cman_tool leave
remove' when calling the init script with the 'stop' argument. Is this the
correct thing to do?

According to the cman_tool man page, 'leave remove' should be done when the node
is expected to be offline to an extended period of time.

If having 'cman_tool leave remove' be the default operation is ok, then is there
any need to add a new option? For example, we could add a 'stopremove' command
to the cman init script, but is that desirable?
Comment 6 Ryan O'Hara 2008-07-28 15:47:47 EDT
BZ #179627 made 'cman_tool leave remove' the default behavior when calling
'service cman stop'.

Comment 7 Christine Caulfield 2008-07-29 03:38:19 EDT
Personally I don't like having "cman_tool leave remove" as the default. Though
if its been shipped like that it's probably hard to change it back.
Comment 8 Ryan O'Hara 2008-07-29 12:11:50 EDT
Yes, I agree. It seems that the default should be to simply 'leave'. What are
the risks associated with moving back to having the default case be to just call
'cman_tool leave'?

It seems that this bug is asking for an option such that we can tell the init
script that we want to do a 'leave remove' as opposed to a 'leave'. But since
the default case is the do a 'leave remove', there is nothing to do for this BZ.
However, if we go back to 'leave' being the default (which I think is correct),
I think adding a 'stopremove' command to the init script makes sense.

The way to init script is coded at the moment is weird. It checks $2 to see if
it is defined (it never actually uses this parameter). If it is, then we do a
'cman_tool leave'. If it is not defined, we do a 'cman_tool leave remove'
(default). The result is:

% service cman stop  =>  'cman_tool leave remove'

% service cman stop foo  =>  'cman_tool leave'

where "foo" can be ANYTHING. Hrm. That doesn't seem right.

Comment 9 Thorsten Scherf 2008-07-31 17:03:23 EDT
are you sure that quorum is recalculated when you stop cman? haven't tested that
for a while. will do that tomorrow and provide further infos then.
Comment 10 Ryan O'Hara 2008-08-11 11:57:16 EDT
(In reply to comment #9)
> are you sure that quorum is recalculated when you stop cman? haven't tested that
> for a while. will do that tomorrow and provide further infos then.

Yes. I tested this recently, and according to the output from 'cman_tool status', quorum is recalculated after you for a 'service cman stop'. Test was done on RHEL 5.2.
Comment 11 Ryan O'Hara 2008-08-13 20:13:14 EDT
Closing this since 'cman_tool leave remove' is the defaults behavior in RHEL5. This was changed with BZ 179627.
Comment 12 Ryan O'Hara 2008-08-13 20:15:46 EDT
(In reply to comment #9)
> are you sure that quorum is recalculated when you stop cman? haven't tested that
> for a while. will do that tomorrow and provide further infos then.

Also wanted to note that if you observe that 'service cman stop' does not result in quorum being recalculated, it could be a bug with 'cman_tool leave remove'. If that is the case, please note the version of cman you are using and create a new bug. Thanks!
Comment 13 Thorsten Scherf 2008-08-14 07:01:45 EDT
ok, thanks, will let you know if I observe further issues.

Note You need to log in before you can comment on or make changes to this bug.