Bug 442127 - krdc: segmentation fault in QPixmap::fromImage
krdc: segmentation fault in QPixmap::fromImage
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 17:28 EDT by Orion Poplawski
Modified: 2008-04-14 12:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.0.3-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 12:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 160728 None None None Never

  None (edit)
Description Orion Poplawski 2008-04-11 17:28:13 EDT
Description of problem:

Running krdc vnc connection.  If you kill the remote VNC server, krdc dies with
the following backtrace:

#0  0x03da0761 in QPixmap::fromImage (img=<value optimized out>,
    flags=<value optimized out>) at image/qpixmap_x11.cpp:1438
#1  0x03dc6993 in QPaintEngine::drawImage (this=Could not find the frame base
for "QPaintEngine::drawImage(QRectF const&, QImage const&, QRectF const&,
QFlags<Qt::ImageConversionFlag>)".
)
    at painting/qpaintengine.cpp:536
#2  0x03e4b299 in QX11PaintEngine::drawImage (this=<value optimized out>,
    r=<value optimized out>, image=<value optimized out>,
    sr=<value optimized out>, flags=Could not find the frame base for
"QX11PaintEngine::drawImage(QRectF const&, QImage const&, QRectF const&,
QFlags<Qt::ImageConversionFlag>)".
) at painting/qpaintengine_x11.cpp:1595
#3  0x03dd1fcb in QPainter::drawImage (this=<value optimized out>,
    targetRect=<value optimized out>, image=<value optimized out>,
    sourceRect=<value optimized out>, flags=Could not find the frame base for
"QPainter::drawImage(QRectF const&, QImage const&, QRectF const&,
QFlags<Qt::ImageConversionFlag>)".
) at painting/qpainter.cpp:4448
#4  0x08063f0d in _start ()

Version-Release number of selected component (if applicable):
qt-4.3.4-11.fc9.i386
Comment 1 Orion Poplawski 2008-04-12 10:15:00 EDT
I filed in KDE as well and it looks like the krdc maintainer has a possible fix.
Comment 2 Kevin Kofler 2008-04-12 12:48:30 EDT
Should be fixed in 4.0.3-5.fc9.
http://koji.fedoraproject.org/koji/taskinfo?taskID=563442
Sending tagging request.
Comment 3 Kevin Kofler 2008-04-13 14:36:30 EDT
kdenetwork-4.0.3-5.fc9, which should fix this, tagged f9-final, should hit 
Rawhide tonight / tomorrow morning.
Comment 4 Orion Poplawski 2008-04-14 12:44:35 EDT
Nope.  Same problem.
Comment 5 Rex Dieter 2008-04-14 12:56:57 EDT
Ugh, let's continue tracking this upstream.

Note You need to log in before you can comment on or make changes to this bug.