Bug 442131 - Menu launcher requires root password to be useful
Menu launcher requires root password to be useful
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: etherape (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Rice
Fedora Extras Quality Assurance
:
: 241044 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 18:33 EDT by J French
Modified: 2008-04-19 10:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 10:48:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J French 2008-04-11 18:33:59 EDT
Description of problem:
Etherape requires root privileges to operate properly. On normal install, it
launches from the main menu as the logged in user, then errors to "no devices
found".

Version-Release number of selected component (if applicable):
0.9.7-5

How reproducible:
Every time

Steps to Reproduce:
1. yum install etherape
2. Applications > System Tools > Etherape
  
Actual results:
Etherape is unusable, to use you have to open a terminal, login as root and then
run etherape.

Expected results:
Should ask for root password, then launch as root.

Additional info:
Fixed with (call me lazy, I just copied pirut):
mv /usr/bin/etherape /usr/sbin/etherape

ln -s consolehelper /usr/bin/etherape

cp /etc/pam.d/pirut /etc/pam.d/etherape

sed s/pirut/etherape/ /etc/security/console.apps/pirut >
/etc/security/console.apps/etherape
Comment 1 Ignacio Vazquez-Abrams 2008-04-18 20:20:36 EDT
*** Bug 241044 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.