Bug 442140 - [PATCH] PV guest domain has the different port number from installation
Summary: [PATCH] PV guest domain has the different port number from installation
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt   
(Show other bugs)
Version: 5.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 409971
TreeView+ depends on / blocked
 
Reported: 2008-04-12 00:38 UTC by Bryan Mason
Modified: 2018-10-20 01:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:21:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.35 KB, patch)
2008-04-12 00:38 UTC, Bryan Mason
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0142 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2009-01-20 16:05:03 UTC

Description Bryan Mason 2008-04-12 00:38:50 UTC
Description of problem:

    The port number, which is specified as '--vncport' option with
    'virt-install' at guest creation, is not used when the PV guest
    domain is started by 'virsh start' command, even though
    'vncdisplay' is described at the configuration file.

Version-Release number of selected component (if applicable):

    /python-virtinst-0.300.2-5.el5  

How reproducible:

    Every time

Steps to Reproduce:

    1. Create a PV guest domain with '--vncport' option

       # virt-install --name=guest_dom --paravirt --vnc --vncport=5930

   2. Check the port number

      # virsh vncdisplay guest_dom
     :30

   3. Start the guest domain after creating the guest

      # virsh start guest_dom

   4. Check the port number

      # virsh vncdisplay guest_dom
      :0

 
Actual results:

    An arbitrary unused port number is used when the PV guest domain
    is started by 'virsh start'.

Expected results:

    The port number, which is specified as '--vncport' option with
    'virt-install' at guest creation, is used for the PV guest domain.

Additional info:

    Proposed patch attached.  Customer has verified that the patch 
    fixes the problem.

Comment 1 Bryan Mason 2008-04-12 00:38:50 UTC
Created attachment 302184 [details]
Proposed patch

Comment 2 RHEL Product and Program Management 2008-06-02 20:07:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Cole Robinson 2008-06-12 15:54:13 UTC
Hi, looks like your patch is against libvirt, so I'm reassigning to that component.

Comment 4 Daniel Berrange 2008-07-04 16:29:27 UTC
The patch looks reasonable to me, recommend approving for 5.3

Comment 15 errata-xmlrpc 2009-01-20 21:21:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0142.html


Note You need to log in before you can comment on or make changes to this bug.