Bug 442155 - yum update aborts on rhpxl, probably right before cleanup phase
yum update aborts on rhpxl, probably right before cleanup phase
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 00:35 EDT by Kai Engert (:kaie)
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 16:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2008-04-12 00:35:35 EDT
Rawhide, x86_64, very recent snapshot, the update/remove count is just 112.

I started with "yum update -y" while running screen.
It aborted right after having updated package rhpxl and gave a traceback, which
follows:

(Note: "Aktualisiere" is german for "Updating")

  Aktualisie: xorg-x11-server-Xorg         ##################### [ 48/112]
  Aktualisie: NetworkManager-glib          ##################### [ 49/112]
  Aktualisie: NetworkManager-glib          ##################### [ 50/112]
  Aktualisie: NetworkManager               ##################### [ 51/112]
  Aktualisie: NetworkManager               ##################### [ 52/112]
  Aktualisie: xorg-x11-drv-keyboard        ##################### [ 53/112]
  Aktualisie: NetworkManager-gnome         ##################### [ 54/112]
  Aktualisie: xorg-x11-drv-nouveau         ##################### [ 55/112]
  Aktualisie: rhpxl                        ##################### [ 56/112]
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 188, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 430, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 764, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 323, in callback
    self._unInstStop( bytes, total, h )
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 415, in _unInstStop
    self.total_actions)
  File "/usr/share/yum-cli/output.py", line 750, in event
    sys.stdout.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 7:
ordinal not in range(128)


[root@kf ~]# yum update -y
Geladene Plugins: refresh-packagekit
Einrichten des Aktualisierungsprozess
Keine Pakete für die Aktuslisierung angegeben



As you can see, I attempted to run yum update again, but this time it said "no
updates available".

It appears that yum has completed the "install" phase, and aborted right before
the "cleanup" phase.

I suspect that, because 112 / 2 => 56
Comment 1 Seth Vidal 2008-04-14 16:36:13 EDT
Could you please test this version of yum:
http://koji.fedoraproject.org/packages/yum/3.2.14/7.fc9/noarch/yum-3.2.14-7.fc9.noarch.rpm
thanks
Comment 2 Kai Engert (:kaie) 2008-04-15 16:07:06 EDT
Your package looks good, today's yum update completed successfully.

(Before that, I had seen the above bug several days in a row)

Note You need to log in before you can comment on or make changes to this bug.