Bug 442160 - Miro does not return search results from video sharing sites
Miro does not return search results from video sharing sites
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 04:10 EDT by Peter Janakiev
Modified: 2008-04-12 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 11:06:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2008-04-12 04:10:23 EDT
Description of problem:
The newest version of Miro seem to no longer handle the video search function
for youtube/dm/all


Version-Release number of selected component (if applicable):
Miro-1.2-1.fc8

How reproducible:
Always

Steps to Reproduce:
1.Start Miro and click on "Video search", or use tool at the bottom panel -
search all, type in some search term and press go 
2.
3.
  
Actual results:
The Video search page is opened but is stays forever to "Searching.."

Expected results:
Display found video or at least display "No matches found".

Additional info:
2008-04-12 11:03:48,961 INFO     got action:updateLastSearchQuery?query=a
2008-04-12 11:03:49,064 INFO     got action:updateLastSearchQuery?query=av
2008-04-12 11:03:49,144 INFO     got action:updateLastSearchQuery?query=ava
2008-04-12 11:03:49,386 INFO     got action:updateLastSearchQuery?query=avare
2008-04-12 11:03:49,438 INFO     got action:updateLastSearchQuery?query=avare
2008-04-12 11:03:49,660 INFO     got action:updateLastSearchQuery?query=avarech
2008-04-12 11:03:49,702 INFO     got action:updateLastSearchQuery?query=avarech
2008-04-12 11:03:49,898 INFO     got action:updateLastSearchQuery?query=avarech
2008-04-12 11:03:49,903 INFO     got
action:performSearch?engine=youtube&query=avarech
2008-04-12 11:05:16,655 TIMING   timeout (Save database) too slow (3.097 secs)
2008-04-12 11:05:16,760 TIMING   timeout (Save database) cumulative is too slow
(5.550 secs)
2008-04-12 11:05:27,578 TIMING   timeout (Save database) too slow (0.923 secs)
2008-04-12 11:07:29,407 TIMING   timeout (Save database) too slow (1.413 secs)

It appears like the request goes forever, 5 minutes later nothing...
Comment 1 Alex Lancaster 2008-04-12 04:34:23 EDT
I can't duplicate this on Fedora 8.   Video search works just fine, tried
several different keywords, they all returned results both from the Video Search
tab and the search bar at the bottom.  

Can you backgrade to 1.1.2 to see if worked for you there?   Are you sure that
there might not have been some transient network configuration issue?
Comment 2 Peter Janakiev 2008-04-12 10:35:57 EDT
No, I cant, because the DB is different, once u run Miro 1.2 with your ~/.miro
you can no longer downgrade. 
But I did something else, mv ~/.miro ~/.miro_backup and then run miro

It looks like something in my settings from the older versions is preventing it
from working, i then mv-ed back the old .miro dir and it is not working again. I
cant get rid of my old dir, it stored many many videos and feeds, i dont want to
loose those. 

What else can i do?
Comment 3 Peter Janakiev 2008-04-12 10:37:53 EDT
I tried and delete ~/.miro/mozilla but it is still not working... 
Please advise;)
Comment 4 Alex Lancaster 2008-04-12 10:43:01 EDT
(In reply to comment #3)
> I tried and delete ~/.miro/mozilla but it is still not working... 
> Please advise;)

Try re-installing the older version of Miro (1.1.2) that worked for you.  

I can't duplicate this and I highly doubt that it is a problem in Miro itself,
but possibly with your network connection (e.g. maybe some of proxy) or
otherwise in the miro configuration.

Try also removing everything under ~/.miro/
Comment 5 Alex Lancaster 2008-04-12 10:45:19 EDT
(In reply to comment #2)
> No, I cant, because the DB is different, once u run Miro 1.2 with your ~/.miro
> you can no longer downgrade. 
> But I did something else, mv ~/.miro ~/.miro_backup and then run miro
> 
> It looks like something in my settings from the older versions is preventing it
> from working, 

Ah, so it works if you remove the ~/.miro directory completely.  So it's a
configuration issue.

> What else can i do?

Try taking the issue with upstream Miro, this is out of scope here, as it
doesn't seem to be a packaging bug:

http://bugzilla.pculture.org/
Comment 6 Alex Lancaster 2008-04-12 10:47:19 EDT
I would ask on the miro forums etc:

https://www.getmiro.com/forum/

It's probably something buried in a configuration file.  You could try removing
them one by one to see when it starts working.
Comment 7 Peter Janakiev 2008-04-12 11:06:04 EDT
Oh, Okay,,,
I know even know how to reproduce it, it seem to be caused by saving searches.
I will send this as a bug on miro site

Note You need to log in before you can comment on or make changes to this bug.