This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 44217 - Possible glibc binary incompatibility (KDE Control Center crashes when selecting crypto)
Possible glibc binary incompatibility (KDE Control Center crashes when select...
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-12 03:03 EDT by Stephen Rasku
Modified: 2016-11-24 09:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 13:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2001-06-12 03:03:34 EDT
How Reproducible:	100%

Steps to Reproduce:
1.  Open KDE Control Center
2.  Select Personalization | Crypto

Actual Results:
	
The KDE Control Center crashes with the following error message:

	There was an error loading the module.
	The diagnostics is:
	symbol __sysconf, version GLIBC_2.2 not defined in file libc.so.6 with
link time 
	reference

Additional Information:

	KDE:	2.2alpha2
	openssl:	0.9.6a-5
Comment 1 Bernhard Rosenkraenzer 2001-06-26 13:31:07 EDT
I can't reproduce this (glibc 2.2.3-12 i686)...
Looks like a glibc binary incompatibility though. Jakub, did you change 
__sysconf versioning recently and fix it later?
Comment 2 Jakub Jelinek 2002-08-12 09:33:40 EDT
readelf -s /lib/i686/libc.so.6 | grep sysconf
   155: 4209f010   420 FUNC    WEAK   DEFAULT   11 sysconf@@GLIBC_2.0
  1753: 4209f010   420 FUNC    GLOBAL DEFAULT   11 __sysconf@@GLIBC_2.2
  3369: 4209f010   420 FUNC    WEAK   DEFAULT   11 sysconf
  4967: 4209f010   420 FUNC    GLOBAL DEFAULT   11 __sysconf

Note You need to log in before you can comment on or make changes to this bug.