Bug 442189 - stop automounting during installation
stop automounting during installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 11:22 EDT by Rahul Sundaram
Modified: 2015-03-03 17:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 02:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-04-12 11:22:42 EDT
Description of problem:


The live cd automounts removable media which is a pain in the live cd
environment during installation. We should disable that during installation.  

http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/2008/04/12#2008-04-12-desktop-automount-pain
Comment 1 David Zeuthen 2008-04-12 11:35:07 EDT
(In reply to comment #0)
> Description of problem:
> 
> 
> The live cd automounts removable media which is a pain in the live cd
> environment during installation. We should disable that during installation.  

Automounting is disabled when the installer _runs_. Your complaint is unclear,
but I think this is what you mean right? [1]

[1] : as opposed to completely disabling automounting which, of course, is not
going to happen; if the installer can't cope with unmounting devices it needs
itself it's an installer bug etc.

If automount is happening even during install then it's a bug somewhere and you
need to provide more evidence that it isn't. For example in for of output of
'lshal --monitor' annotated with information such as "I started the installer
here" etc.

>
http://www.chiark.greenend.org.uk/ucgi/~cjwatson/blosxom/2008/04/12#2008-04-12-desktop-automount-pain

Why is it useful to provide a link Ubunutu's live CD and some rant from some
person obviously unaware of what component does automounting these days? (hint:
it's Nautilus now).

This bug report is invalid because it doesn't contain enough information to
describe the problem. Rahul, you need to do a better job here.
Comment 2 Rahul Sundaram 2008-04-12 12:01:08 EDT
There are few examples here:

You see a media icon for the live cd or USB you have just booted from and you
can try doing things like unmount it which will fail. That icon is useless and
should disappear.

Another is that during installation, as soon as a boot partition is created, it
gets opened in the live cd environment. 

I think it did mount other usb keys during installation but I will verify and
get that on that. The above link shows what kind of settings to disable based on
the desktop environment. The rant itself isn't much useful. Agreed. 
Comment 3 David Zeuthen 2008-04-12 12:21:20 EDT
(In reply to comment #2)
> There are few examples here:
> 
> You see a media icon for the live cd or USB you have just booted from and you
> can try doing things like unmount it which will fail. That icon is useless and
> should disappear.

Far from useless; vendors may put files in the root dir of the livecd so they
are accessible from e.g. Windows or Mac OS X.
 
> Another is that during installation, as soon as a boot partition is created, it
> gets opened in the live cd environment. 

That's a nautilus bug because, I presume, /boot gets mounted from the installer
itself [1] and then the bug is that Nautilus opens a window. So please file a
bug against Nautilus instead of the live cd components.

[1] : Again you leave me no choice but guessing what is happening. That's not
useful. I specifically asked for information even giving you clues how to obtain
it (annotated output of 'lshal --monitor'). And I explained I closed this bug
because such data is needed. So it's a little rude of you to simply reopen the
bug without providing clear data. Thanks.

> I think it did mount other usb keys during installation but I will verify and
> get that on that. The above link shows what kind of settings to disable based on
> the desktop environment. The rant itself isn't much useful. Agreed. 

I've sent private mail to Colin since his blog doesn't support comments.
Comment 4 Rahul Sundaram 2008-04-12 12:39:34 EDT
The umount option on the live cd or USB context menu will fail every single time
and that particular option in the context menu is useless on the live cd
environment.  

I am not sure what lshal has to do with this. The /boot gets mounted by nautilus
regardless of the hardware on every system I have done a installation on. Please
try this before asking for more information. Anyway since you are so inclined to
close this bug report so fast, I will just leave it closed. 
Comment 5 David Zeuthen 2008-04-12 12:53:42 EDT
(In reply to comment #4)
> The umount option on the live cd or USB context menu will fail every single time
> and that particular option in the context menu is useless on the live cd
> environment.  
> 
> I am not sure what lshal has to do with this. 

Because I asked for it to help resolve your problem? I am not sure why it's
useful to second guess someone who's trying to help you.

> The /boot gets mounted by nautilus
> regardless of the hardware on every system I have done a installation on. 

That's an interesting assumption (that Nautilus mounts it). And it is most
likely wrong. Instead, I think /boot is mounted by the installer (Of course the
/boot partition needs to get mounted. How else do you expect the installer to
put data there?). 

Listen, as I said in comment 3 my suspicion is that Nautilus has a bug where it
auto-opens a window every time someone mounts someone. Which is a bug: Nautilus
 should only auto-open a window for things Nautilus itself automounts.

So can you please provide the lshal output so we can verify this is a Nautilus
bug? When that is verified we can file a bug against Nautilus and then get it
fixed there. Thanks.
Comment 6 David Zeuthen 2008-04-16 02:12:08 EDT
These patches should fix the side effects being reported here

http://mail.gnome.org/archives/nautilus-list/2008-April/msg00040.html
Comment 7 David Zeuthen 2008-04-16 02:49:17 EDT
These patches are now in

gvfs-0.2.3-4.fc9
nautilus-2.22.2-3.fc9
Comment 8 Colin Watson 2008-04-16 05:45:30 EDT
Thanks to David for clearing the confusion up by e-mail with me. We'll integrate
these and follow up in the event that there's still a problem somewhere else.

(For the record, I don't need people to file bugs on my behalf based on my blog,
in future; I'm entirely capable of filing them myself once I've drilled down to
where. At the time I was about to go away for the weekend and needed to blow off
steam without having time to figure out the proper bug target.)

Note You need to log in before you can comment on or make changes to this bug.