Bug 442212 - X crashes when attempting to use wiimote driver
X crashes when attempting to use wiimote driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libwiimote (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 16:36 EDT by Alex Wauck
Modified: 2008-04-26 02:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 02:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is an xorg.conf that works. (633 bytes, text/plain)
2008-04-19 13:54 EDT, Alex Wauck
no flags Details
This is the log file resulting from using the working xorg.conf. (33.47 KB, text/plain)
2008-04-19 13:55 EDT, Alex Wauck
no flags Details
This is the xorg.conf that causes the crash. (632 bytes, text/plain)
2008-04-19 13:55 EDT, Alex Wauck
no flags Details
This is the log file from an xorg crash. (32.68 KB, text/plain)
2008-04-19 13:56 EDT, Alex Wauck
no flags Details
Console output from running X with the non-working xorg.conf (1.03 KB, text/plain)
2008-04-19 13:57 EDT, Alex Wauck
no flags Details

  None (edit)
Description Alex Wauck 2008-04-12 16:36:17 EDT
Description of problem:
When attempting to use the wiimote driver, X crashes.  If I'm lucky, I can get a
clean shutdown by pressing my computer's power button a few times.  If I ssh
into the machine and launch X from there, I can see the following:

wiimote_select_device(): socket: Permission denied
X: symbol lookup error: /usr/lib/libcwiimote.so.0: undefined symbol: hci_devba


If I run LD_PRELOAD="/usr/lib/libbluetooth.so.2" startx, I get the following:

wiimote_select_device(): socket: Permission denied
wiimote_connect(): devba: Permission denied
wiimote_api.c(39): wiimote_open(): unable to connect to host


Version-Release number of selected component (if applicable):
xorg-x11-drv-wiimote: 0.0.1
X: 1.4.99.901

How reproducible:

Steps to Reproduce:
1. Add an input device section for the wiimote as described on the package's website
2. add it to the server layout
3. Restart X
  
Actual results:
Black screen with strange flickering.

Expected results:
Wiimote awesomeness!  Or at least the ability to do something.


Additional info:
Comment 1 Matěj Cepl 2008-04-17 11:06:16 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Alex Wauck 2008-04-17 14:35:34 EDT
If I use the default xorg.conf (and I suspect if I remove it as well), it will
not use the wiimote driver, and everything will work fine (except for the
wiimote).  I'll try to get the log and xorg.conf uploaded later today.
Comment 3 Alex Wauck 2008-04-19 13:54:41 EDT
Created attachment 303007 [details]
This is an xorg.conf that works.
Comment 4 Alex Wauck 2008-04-19 13:55:28 EDT
Created attachment 303008 [details]
This is the log file resulting from using the working xorg.conf.
Comment 5 Alex Wauck 2008-04-19 13:55:53 EDT
Created attachment 303009 [details]
This is the xorg.conf that causes the crash.
Comment 6 Alex Wauck 2008-04-19 13:56:26 EDT
Created attachment 303010 [details]
This is the log file from an xorg crash.
Comment 7 Alex Wauck 2008-04-19 13:57:25 EDT
Created attachment 303011 [details]
Console output from running X with the non-working xorg.conf
Comment 8 Alex Wauck 2008-04-19 13:59:25 EDT
Judging by the errors, it looks like this may be a problem with libcwiimote.so.0
instead of X.
Comment 9 Matěj Cepl 2008-04-21 06:35:12 EDT
Right you are.
Comment 10 Adam Jackson 2008-04-22 14:40:38 EDT
Well, fixed libcwiimote to be linked correctly anyway.  That's sorted in
libwiimote-0.4-6.fc9 and later.

I'm still not completely sure how to get the input device to magically plug in
and work though.  If you come up with a solid recipe I'd love to hear it, I
doubt I'll be able to get to it on my own before F9.
Comment 11 Alex Wauck 2008-04-25 17:18:34 EDT
The crash was fixed.  I think some development work on BlueZ or xinput is
necessary before Wiimotes work automatically.
Comment 12 Matěj Cepl 2008-04-26 02:34:32 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.