Bug 442247 - anaconda doesn't properly handle a tune2fs failure in graphical mode
anaconda doesn't properly handle a tune2fs failure in graphical mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-13 07:28 EDT by G.Wolfe Woodbury
Modified: 2008-04-14 16:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 16:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2008-04-13 07:28:01 EDT
Description of problem:
    during graphical install the formatting of the / filesystem fails due to an
input/output error that is not caught or detected.  This is after formatting,
before doing the /boot filesystem.
    this is a consistent bug, but it only occurs with the graphical installer on
my system.  Doing a text install works.

Version-Release number of selected component (if applicable):
  anaconds-11.4.0.71

How reproducible:
  consistently

Steps to Reproduce:
1. boot.iso install via NFS method to local repo mirror
2. configure default root
3. commit
  
Actual results:
    the partion writes work, and the make2fs works, but the tune2fs call to set
acl modes on the root parition consistently fail when in the graphical bbt
environment.  Text mode installs work correctly.  The error is *not* trapped by
anaconda and no opportunity to save the traceback occurs.  Unless one looks a
vt03 and vt05 during the install cycle it would appear to just hang with the
root filesystem format at 99%

Expected results:


Additional info:
http://www.smolts.org/client/show/pub_5b4371f7-d567-4b8a-a2b9-358e41f3f736
Comment 1 Jeremy Katz 2008-04-14 10:04:50 EDT
I was doing a lot of installs successfully on Friday.  What is the actual error
message on tty5?  And are there kernel errors on tty4?
Comment 2 G.Wolfe Woodbury 2008-04-14 13:14:02 EDT
I try another graphical install today and record as much as I can.
Comment 3 G.Wolfe Woodbury 2008-04-14 16:33:16 EDT
Today's install worked pretty well. I had to use a new CD-RW for the boot.iso as
there were some read block issues.

I have to presume that this "bug" was actually an error in the boot.iso read of
stage2.img

?
How does one specify in the new anaconda regime that one wants to fetch stage2
from the nfs mount rather than the local cd?
?

Note You need to log in before you can comment on or make changes to this bug.