Bug 442257 - Network partially started?
Summary: Network partially started?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-13 14:25 UTC by Anne
Modified: 2009-02-20 16:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 16:02:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anne 2008-04-13 14:25:04 UTC
Description of problem:
Since Friday's update (11th Apr.) at bootup the network icon on the tray shows
no connection.  ifconfig returns all that's expected.  ping says 'Network is
unreachable.  'network-service-restart' shuts down, and bringing up eth0 causes
a longish delay, but after that everything works.  The icon still says 'no
network connection'

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
No network activity possible without restarting the network.

Expected results:
Network active from bootup.

Additional info:

Comment 1 Anne 2008-04-14 15:26:58 UTC
The pause appears to be around 6 seconds.  

I should have added that the network uses static IP.

Comment 2 Dan Williams 2008-04-14 16:03:04 UTC
What items are in the left-click dropdown menu of the NM applet?

What's the output of /usr/bin/nm-tool?

Comment 3 Anne 2008-04-16 15:15:58 UTC
NM applet -
Enable Networking (checked)
Edit Connections (everything greyed out)

/usr/bin/nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            8139too
  State:             disconnected
  HW Address:        00:00:00:00:00:00

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings


The connection keeps dropping out, although it is active at the moment.

Comment 4 Anne 2008-04-24 16:12:55 UTC
On starting the box this morning I discovered that it automatically connected. 
This is the first time since the 11th.  Maybe something changed in yesterday's
update?

It will take a little time before I know whether it's totally stable, but it
seems to have only dropped out once in the last couple of hours, a definite
improvement.

Comment 5 Bug Zapper 2008-05-14 09:22:40 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Anne 2008-05-21 14:53:14 UTC
Cabled connections appear to work normally now.

Comment 7 John J. McDonough 2008-06-17 13:04:03 UTC
Possibly related -- I noticed that on FC8 as well as FC9, when a static IP is 
specified during install, some network config is static, and some is DHCP even 
though static is specified.  Network does work (sort of) on reboot without 
restarting network if DHCP server is configured to deliver same information as 
specified for static IP.


Comment 8 Anne 2008-06-17 15:42:18 UTC
I confirm that I did set the network to static during install.

Comment 9 Dan Williams 2009-02-20 14:52:58 UTC
Is this still an issue with latest NM and kernel updates?

Comment 10 Anne 2009-02-20 15:35:34 UTC
I think it's safe to say that this is now fixed, thanks

Comment 11 Dan Williams 2009-02-20 16:02:04 UTC
Ok, thanks!


Note You need to log in before you can comment on or make changes to this bug.