Bug 442279 - Reporting of temperature could use more sensible values.
Reporting of temperature could use more sensible values.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-13 15:13 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 06:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-04-13 15:13:57 EDT
My /var/log/messages is filled with messages like..

Apr 13 05:36:52 pressure smartd[2553]: Device: /dev/sda, SMART Usage Attribute:
194 Temperature_Celsius changed from 137 to 141
Apr 13 05:36:53 pressure smartd[2553]: Device: /dev/sdc, SMART Usage Attribute:
194 Temperature_Celsius changed from 113 to 114

If the drives were over 100C, it would be somewhat alarming.

Running smartctl -a on the drives, I see..
194 Temperature_Celsius     0x0002   141   141   000    Old_age   Always       -
      39 (Lifetime Min/Max 16/47)

Note the last column.  I think it's very likely that '39' is 39C.  
Reporting the raw value to the log is going to be much more useful.

This seems to be the case on all three drives I've tested on in that machine (A
mix of maxtor, hitachi and WD's)
Comment 1 Tomas Smetana 2008-04-14 05:16:31 EDT
The "big numbers" are the normalized values.  Those are reported by the firmware
and tracked by smartd and therefore reported to the log.  The conversion is also
defined by the firmware.  If you wish to have also the raw values reported you
may add '-r' option in the smartd.conf.

Note You need to log in before you can comment on or make changes to this bug.