Bug 442294 - pm-utils on x86_64 looks for files in /usr/lib
pm-utils on x86_64 looks for files in /usr/lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
: 442344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-13 20:52 EDT by Carl Roth
Modified: 2008-04-15 08:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 08:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2008-04-13 20:52:59 EDT
Description of problem:

Some of the plugin scripts in pm-utils for x86_64 erroneously look for scripts
in /usr/lib.  Specifically,

  sleep.d/95packagekit
  sleep.d/99hd-apm-restore.hook

These scripts should probably use the $PM_UTILS_LIBDIR variable instead.

Version-Release number of selected component (if applicable):

pm-utils-1.1.0-4.fc9.x86_64

How reproducible:

Always

Steps to Reproduce:
1. type 'pm-suspend'
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Till Maas 2008-04-14 14:37:31 EDT
*** Bug 442344 has been marked as a duplicate of this bug. ***
Comment 2 Till Maas 2008-04-14 17:50:41 EDT
sleep.d/99hd-apm-restore.hook will be fixed tomorrow. I need to test my changes
more, before I commit them to cvs. sleep.d/95packagekit needs to be fixed in
PackageKit (At least it is not included in pm-utils), I will take a look there
tomorrow.
Comment 3 Till Maas 2008-04-15 08:45:44 EDT
A fix for sleep.d/99hd-apm-restore.hook has been commited and built.
Comment 4 Till Maas 2008-04-15 08:46:34 EDT
For the other file, there I created bug #442531

Note You need to log in before you can comment on or make changes to this bug.