Bug 442408 - LTC:5.3:201589:Extend mkinitrd with the possibility of extracting the nfs root-path option received via dhcp
LTC:5.3:201589:Extend mkinitrd with the possibility of extracting the nfs roo...
Status: CLOSED DUPLICATE of bug 254166
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
other All
low Severity high
: rc
: ---
Assigned To: Peter Jones
: FutureFeature, OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 14:00 EDT by IBM Bug Proxy
Modified: 2009-06-19 23:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 16:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 44047 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-04-14 14:00:41 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-04-14 13:29 EDT
1. Feature Id:	[201589]
Bugzilla Id:	https://bugzilla.linux.ibm.com/show_bug.cgi?id=38145
https://bugzilla.redhat.com/show_bug.cgi?id=254166
Feature Name:	Extend mkinitrd with the possibility of extracting the nfs root-path option received
via dhcp
Sponsor:	QDC
Category:	Cell
Request Type:	Installer - Enhancement from Distributor

2. Short Description
This feature request requests to extend mkinitrd with the possibility of extracting the nfs
root-path option received via dhcp. By booting the kernel with 'root=/dev/nfs' nash would extract
the root-path information. Otherwise it would behave as usual. The pseudo-device '/dev/nfs' is also
used in the Kernel based IP autoconfiguration. This feature makes it possible to create only one
zImage.initrd resp. initrd for many diskless Cell blades. This functionality is already included in
Fedora 9, see Red Hat bugzilla 248575: DHCP root-path option isn't supported in nash. Backported
patches to the mkinitrd and libdhcp as contained in RHEL5.2 are available in LTC bug 38145 -
RH254166- DHCP root-path option isn't supported in nash. (
https://bugzilla.redhat.com/show_bug.cgi?id=254166 )

3. Business Case
Enhance usability of the RHEL5 system for Cell blade users.


4. Sponsor Priority	2
IBM Confidential:	no
Code Contribution:	IBM code
Upstream Acceptance:	Accepted
Component Version Target:	mkinitrd-6.0.10-1, libdhcp-1.25
Performance Assistance:	

5. PM Contact:	Hanns-Joachim Uhl, hannsj_uhl@de.ibm.com, 49-7031-16-4198

6. Technical contact(s):

Hanns-Joachim Uhl, hannsj_uhl@de.ibm.com
Comment 1 Peter Jones 2008-04-30 16:23:25 EDT

*** This bug has been marked as a duplicate of 254166 ***

Note You need to log in before you can comment on or make changes to this bug.