Bug 442464 - livecd-creator and selinux issues
livecd-creator and selinux issues
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 17:48 EDT by Kevin Fenzi
Modified: 2008-04-15 15:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 15:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2008-04-14 17:48:19 EDT
Using livecd-creator under rawhide to try and make a Xfce live cd. 

Everything moves along normally until: 

Installing: setroubleshoot               #####################
[911/911]/usr/sbin/setenforce:  setenforce() failed
Only root can do that.
/usr/sbin/setenforce:  setenforce() failed

Needless to say, I am root. The machine is selinux=Permissive. 
Rebooting for selinux=Disabled I get: 

Installing: setroubleshoot               ##################### [911/911]Removing
password for user root.
passwd: Success

When doing a standard desktop with selinux=Permissive, I get:

Installing: setroubleshoot               #####################
[967/967]/sbin/restorecon reset /var/cache/yum/development context
system_u:object_r:tmp_t:s0->system_u:object_r:var_t:s0
/sbin/restorecon reset /var/cache/yum/development/cachecookie context
system_u:object_r:tmp_t:s0->system_u:object_r:var_t:s0
/sbin/restorecon reset /var/cache/yum/development/comps.xml.gz context
system_u:object_r:tmp_t:s0->system_u:object_r:var_t:s0
/sbin/restorecon reset /var/cache/yum/development/packages context
system_u:object_r:tmp_t:s0->system_u:object_r:var_t:s0
...
tons of lines of restorecon
...
Removing password for user root.
passwd: Success

Does some selinux policy need to change to allow Xfce live cd's to be created?
Or am I doing something dumb? :)
Comment 1 Jeremy Katz 2008-04-14 18:50:31 EDT
The restorecons are normal...  the bit about only root being able to do
setenforce is very odd.  Dan -- any thoughts?
Comment 2 Daniel Walsh 2008-04-15 09:47:41 EDT
I have no idea why anyone would be calling setenforce or why it would fail.
Comment 3 Kevin Fenzi 2008-04-15 15:09:48 EDT
Looks like pilot error. ;( 

The .ks file I was using had a 'selinux --disabled' in it. 
That caused all kinds of problems. 

Closing this now. Sorry to bother... 

Note You need to log in before you can comment on or make changes to this bug.