Bug 442490 - Kde4 panel process popups cause very high plasma+Xorg cpu load
Kde4 panel process popups cause very high plasma+Xorg cpu load
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 23:09 EDT by Mark Schlegel
Modified: 2008-04-15 08:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 08:46:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 158349 None None None Never

  None (edit)
Description Mark Schlegel 2008-04-14 23:09:40 EDT
Description of problem:

Load the KDE4 desktop and start a process so that the screen bottom
kde panel shows a process entry. Hover the mouse over the
panel so plasma shows the process details under the mouse-->
Xorg and plasma cpu load goes to 100% (total cpu% of the two)
for as long as the mouse triggers the panel popup for the process.

Version-Release number of selected component (if applicable):

Fedora 9 Beta
kdebase-4.0.3-6.fc9.i386 and
xorg-x11-server-Xorg-1.4.99.901-21.20080407.fc9.i386

How reproducible:

Steps to Reproduce:
1.Load the KDE4 desktop
2. start a process so that the screen bottom kde panel shows a process entry.
3. popup display causes plasma and Xorg cpu usage to go very high
  
Actual results:
xorg/plasma cpu usage goes very high for as long as mouse forces
a panel popup.

Expected results:
plasma should not be designed so that a static popup causes abnormally
high cpu usage.

Additional info:
Comment 1 Matěj Cepl 2008-04-15 07:13:06 EDT
And why is this Xorg and not KDE bug?
Comment 2 Steven M. Parrish 2008-04-15 08:46:22 EDT
Looks like a bug has been filed upstream for this issue.  Checkout 

http://bugs.kde.org/show_bug.cgi?id=158349

You may want to add your comments to that bug report or if you feel it is not a
good fit open a new bug with the KDE folks.
 

Note You need to log in before you can comment on or make changes to this bug.