Bug 442518 - Errors on rsh and rcp commands
Errors on rsh and rcp commands
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsh (Show other bugs)
4.5
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Tkac
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 06:12 EDT by Equipe SMART
Modified: 2013-04-30 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-22 12:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Equipe SMART 2008-04-15 06:12:40 EDT
Description of problem:

Problems with rsh and rcp commands, executed on Red Hat Enterprise Linux 4.5.


The following errors occurs :

++ rsh pz2 -l pospz2 -n mv /pz2/poster/expl_drse/tmp/th_xelem.o
/pz2/poster/expl_drse/tmp/dva.o
poll: protocol failure in circuit setup

++ rcp -p pospz2@pz2:/pz2/poster/expl_drso/tmp/asg.o /poster/expl_drso/tmp
rcmd: srvrmv: short read


The remote server (pz2) is an HP server.


How reproducible:

By using rsh and rcp commands on Red Hat Enterprise Linux 4.5.

This behavior is not systematic : we found it by trying many rcp and rsh commands.
Comment 1 Adam Tkac 2008-04-16 05:15:33 EDT
Would it be possible attach strace output when rsh fails, please? You can use
something like "strace -s 0 rsh pz2 -l pospz2 -n mv
/pz2/poster/expl_drse/tmp/th_xelem.o /pz2/poster/expl_drse/tmp/dva.o" in your
case. Thanks
Comment 2 Adam Tkac 2010-02-22 12:15:16 EST
Red Hat Enterprise Linux 4.9 update will contain only security and performance related fixes. There were no response from reporter since 2008 thus I'm closing this issue.

Note You need to log in before you can comment on or make changes to this bug.