Bug 442566 - configuring sound device to record is too difficult
configuring sound device to record is too difficult
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-media (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 11:26 EDT by Cameron Meadors
Modified: 2016-09-22 11:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2008-04-15 11:26:37 EDT
In order to record sound, one must generally set the capture device and the
capture volume.  In some cases you have to enable captureing.  If you want to
hear the sound coming from the capture device you have to set the monitoring volume.

I have always had to use alsamixer to set this up.  Even that requires a deep
understanding of alsa and the particular sound device.  To use
gnome-volume-control to do the same is like pulling teeth.  I am not sure if
this is a gnome-volume-control, an alsa tools, or alsa drivers bug. I am
starting with gnome-volume-control because it is possible to set up a device to
record with alsamixer.  The fact that you can't, or is it extremely confusing ,
to do with g-v-c is the bug.

Specifics: 
*Not all necessary "tracks" are enabled in gv-c
*Sometime two tracks are listed with the same name.  Turns out one is the
playback volume and the other is the record volume.
*Enabling one of tracks in the above situation sometimes enables both, disabling
the second one disables both, basically you don't get what you think you would.
*selecting the capture device is done with a button that is not exclusive.  It
can look like you have enabled multiple devices for capture, but you really have
only one (this is gleaned from a side by side comparison with alsamixer).
Comment 1 RHEL Product and Program Management 2014-03-07 08:34:03 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-03 08:36:31 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.