This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442602 - libjvm is in a directory called "core"
libjvm is in a directory called "core"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 15:08 EDT by Caolan McNamara
Modified: 2008-04-18 10:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 10:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2008-04-15 15:08:50 EDT
Description of problem:

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.ppc64/jre/lib/ppc64/core/libjvm.so

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-0.8.b08.fc9


Stuff like OOo tries to dlopen libjvm to do its java magic, so it can't find it
at the moment. Typically client is searched for. Is there any particular reason
that openjdk places it in a dir called "core" ?
Comment 1 Caolan McNamara 2008-04-15 15:10:17 EDT
Well actually we search in client, server and classic to be exact
Comment 2 Thomas Fitzsimmons 2008-04-15 15:13:31 EDT
Gary, can you comment here?
Comment 3 Gary Benson 2008-04-15 19:04:26 EDT
Sure.  The directories "client" and "server" are the names of Sun's JITs, but
they're only supported on i386 and x86_64.  No other platform has those, so the
JVM is in the "core" directory (HotSpot calls a build without a JIT a core build).

Can I suggest using a glob rather than checking for fixed paths?  The reason I
say this is that I'm working on a new JIT for the platforms that don't already
have one, so at some time in the future some of those platforms will likely move
from "core" to "shark".  Maybe check "client" first (it's probably the best for
OOo) and fall back to globbing?
Comment 4 Caolan McNamara 2008-04-16 03:07:32 EDT
I'm sure it makes sense from an internal point of view, but from my own naive
pov I'd still have expected to see a fat fake link :-) We have the client/server
dir configuration with java-1.5.0-gcj which was convenient.
Comment 5 Gary Benson 2008-04-16 03:25:11 EDT
It is kind of a legacy of something that doesn't exist any more, thinking about
it.  I'll see how easy it is to change...
Comment 6 Gary Benson 2008-04-16 10:36:13 EDT
Fixed in icedtea6 hg.  The JVM is now in "server".
Comment 7 Lillian Angel 2008-04-18 10:29:45 EDT
Building new version into rawhide, should be in tomorrow.

Note You need to log in before you can comment on or make changes to this bug.