Bug 442638 - libgnomeui-devel at newer version than libgnomeui leads to broken .so symlink
libgnomeui-devel at newer version than libgnomeui leads to broken .so symlink
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 18:58 EDT by David Walluck
Modified: 2008-09-10 04:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 18:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Walluck 2008-04-15 18:58:02 EDT
I am using x86_64. There is a broken symlink libgnomeui-2.so ->
libgnomeui-2.so.0.2201.0 since libgnomeui-2.so.0.2200.0 is installed. This makes
developing with  libgnomeui-2 impossible without manually fixing the symlink.

Name        : libgnomeui-devel             Relocations: (not relocatable)
Version     : 2.22.1                            Vendor: Fedora Project
Install Date: Tue 11 Mar 2008 06:22:50 PM EDT      Build Host:
xenbuilder1.fedora.redhat.com

Name        : libgnomeui                   Relocations: (not relocatable)
Version     : 2.22.01                           Vendor: Fedora Project
Release     : 1.fc9                         Build Date: Mon 10 Mar 2008 06:04:34
PM EDT
Comment 1 Ray Strode [halfline] 2008-04-16 09:39:55 EDT
libgnomeui-devel has:

Requires: %name = %{version}-%{release}

How do you have versions out of sync?
Comment 2 David Walluck 2008-04-16 13:38:26 EDT
rpm -V libgnomeui-devel libgnomeui
....L...    /usr/lib64/libgnomeui-2.so

No broken dependencies, only the link that I changed.

$ rpm -q libgnomeui
libgnomeui-2.22.01-1.fc9.x86_64

$ rpm -q --requires libgnomeui-devel | grep gnomeui
libgnomeui = 2.22.1-1.fc9
libgnomeui-2.so.0()(64bit)

I don't understand how the dependency is satisfied: 2.22.01 != 2.22.1, and these
are built from different src.rpms too: libgnomeui-2.22.01-1.fc9.src.rpm vs.
libgnomeui-2.22.1-1.fc9.src.rpm.

It looks like there is some bug where an old version of libgnomeui was not
upgraded and should have been, but this looks like an rpm/yum bug rather than a
packaging bug at this point.

If I force erase, only then will it upgrade

$ sudo rpm -e --nodeps libgnomeui
$ sudo yum install libgnomeui
Comment 3 Ray Strode [halfline] 2008-04-16 14:31:03 EDT
okay, moving to yum.
Comment 4 James Antill 2008-04-16 14:53:45 EDT
 My guess is that something died in the middle of an upgrade and
yum-complete-transaction would have fixed this.
 Can you give the output of ls in /var/lib/yum

 We can look at doing this automatically when you next run yum, but I'm not sure
that's a Fed-9 thing.
Comment 5 seth vidal 2008-04-16 15:07:16 EDT
also post the output of rpm -Va --nofiles --nomd5

just to make sure there aren't other broken deps.
Comment 6 Bug Zapper 2008-05-14 05:30:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.