Bug 442658 - xinit cannot connect to X server
xinit cannot connect to X server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 22:34 EDT by Keenan Parmelee
Modified: 2008-04-19 03:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 03:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log file for machine where X does not start, Bug 442658 (70.68 KB, text/plain)
2008-04-17 22:35 EDT, Keenan Parmelee
no flags Details
Xorg.0.log for a machine where problem does not occur (42.24 KB, text/plain)
2008-04-17 22:36 EDT, Keenan Parmelee
no flags Details
Xorg.0.log from Fedora 9 Preview - working (80.79 KB, text/plain)
2008-04-18 23:33 EDT, Keenan Parmelee
no flags Details

  None (edit)
Description Keenan Parmelee 2008-04-15 22:34:53 EDT
Description of problem: 
When trying to boot the rawhide KDE live CD, boot fails to start X.  This
problem happens on a machine with the following specifications:

Core 2 Duo E6600
2GB DDR2 RAM
Radeon X1950XT video card

Live CD starts at the command line, asking for a login.  One can log in as root
and use the same functionality that you would expect from the command line.


Version-Release number of selected component (if applicable): 
rawhide KDE Live CD for 20080404, for both i686 and x86_64.


How reproducible:
Every time.

Steps to Reproduce:
1. Boot the KDE Live CD from a computer matching the specifications above.
2. At the command line, login as root.
3. Type 'startx'
  
Actual results:
X begins to start, but ends with this output:

Unblank crtc 0 success
giving up.
xinit: connection refused (errno 111): unable to connect to x server
xinit: no such process (errno 3): server error

Expected results:
X should load, and user should be greeted with a GUI.

Additional info:
The same live CD's will load from a computer with an AMD64 3200+ processor and a
Radeon 9800PRO video card.  This seems to be hardware specific, and since it's
X, I have a feeling it's the video card.  This is my first bug report, so let me
know if you require any additional information from my end.
Comment 1 Matěj Cepl 2008-04-17 11:29:55 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Keenan Parmelee 2008-04-17 22:35:32 EDT
Created attachment 302833 [details]
Xorg.0.log file for machine where X does not start, Bug 442658
Comment 3 Keenan Parmelee 2008-04-17 22:36:30 EDT
Created attachment 302834 [details]
Xorg.0.log for a machine where problem does not occur
Comment 4 Keenan Parmelee 2008-04-17 22:39:36 EDT
I've added two attachments, the Xorg.0.log (Comment #2) for my machine that does
not start X, and the Xorg.0.log.working (Comment #3) file is for the machine
where the same Live CD works.

There was no /etc/X11/xorg.conf file for either machine.
Comment 5 Keenan Parmelee 2008-04-18 23:33:22 EDT
Created attachment 302966 [details]
Xorg.0.log from Fedora 9 Preview - working
Comment 6 Keenan Parmelee 2008-04-18 23:38:50 EDT
I just ran the Preview KDE Live CD (x86_64) and it loads X just fine.  For
anybody curious, I uploaded the Xorg.0.log file in case somebody has time to
compare the two.

Looks like the problem with rawhide is moot, since this problem was resolved
with something in the Preview version.  Thanks!
Comment 7 Matěj Cepl 2008-04-19 03:42:25 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.