Bug 442677 - Sync store recovery problem
Sync store recovery problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity high
: ---
: ---
Assigned To: Kim van der Riet
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 04:30 EDT by Arnaud Simon
Modified: 2012-12-07 12:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 12:41:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Simon 2008-04-16 04:30:26 EDT
Description of problem:
The sync store doesn't delete data, error is: 
 debug Message 0x8c6b5d0 enqueued on
TempQueuecc757ea9-a05f-4c5e-a342-67e2e01c5d26[0x8c69550]
2008-apr-16 10:15:52 debug Exception thrown: duplicate data
(BdbMessageStore.cpp:1357)


Version-Release number of selected component (if applicable):


How reproducible:
Run the Junit test: org.apache.qpid.test.unit.topic.DurableSubscriptionTest
The first test sends a text message "A" to a durable queue, the broker is
stopped between the two tests. It looks as if this message still exist in the
queue after recovery.   

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Arnaud Simon 2008-04-18 04:40:45 EDT
The following tests have been disabled on CC:
org.apache.qpid.test.unit.topic.DurableSubscriptionTest#*
org.apache.qpid.test.unit.xa.TopicTest#testDurSub
org.apache.qpid.test.unit.xa.TopicTest#testMultiMessagesDurSub
org.apache.qpid.test.unit.xa.TopicTest#testDurSubCrash
org.apache.qpid.test.unit.topic.TopicSessionTest#testSubscriptionNameReuseForDifferentTopicSingleConnection
org.apache.qpid.test.unit.topic.TopicSessionTest#testTopicSubscriptionUnsubscription

Note: we must make sure that those tests have been enabled before closing this bug. 
Comment 2 Gordon Sim 2008-05-09 12:13:14 EDT
I can't reproduce this with any of the listed tests (which all pass against the
sync store for me). Arnaud, can you verify whether this issue can be closed?
Comment 3 Arnaud Simon 2008-05-12 10:36:49 EDT
The following tests are still failing during the second run:
org.apache.qpid.test.unit.xa.TopicTest#testDurSub
org.apache.qpid.test.unit.xa.TopicTest#testMultiMessagesDurSub
org.apache.qpid.test.unit.xa.TopicTest#testDurSubCrash

to reproduce run twice in a row the org.apache.qpid.test.unit.xa.TopicTest

NOTES: 
- those tests don't fail with the async store.  
- It looks to me that this is still a recovery issue however this may be another
issue that the one originally reported. 

Comment 4 Gordon Sim 2008-05-14 06:23:52 EDT
Fixed in r 2049 of the store.
Comment 5 Arnaud Simon 2008-05-14 08:48:58 EDT
Tests are now running within CC

Note You need to log in before you can comment on or make changes to this bug.