Bug 442724 - vnc mismatch between client and server monitor
vnc mismatch between client and server monitor
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 09:33 EDT by Mike C
Modified: 2013-04-30 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 04:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg./log at the time when problems occured (52.94 KB, text/plain)
2008-04-16 10:04 EDT, Mike C
no flags Details
Xorg.log with the local user logging in on the server and no problems (48.77 KB, text/plain)
2008-04-16 10:05 EDT, Mike C
no flags Details
kdm.log when the problems occured (3.12 KB, text/plain)
2008-04-16 10:06 EDT, Mike C
no flags Details
kdm.log when local user logged in directly with no problems (10.64 KB, text/plain)
2008-04-16 10:06 EDT, Mike C
no flags Details

  None (edit)
Description Mike C 2008-04-16 09:33:08 EDT
Description of problem:vnc from client with 4:3 screen into server with
widescreen causes loss of parts of display on server.


Version-Release number of selected component (if applicable):vnc-server-4.1.2-20.fc7


How reproducible:Every time


Steps to Reproduce:
1. Log user on server machine in to KDE from vnc session on remote client.
2. Local user on vnc server machine now has missing strip on display to left and
right of their local screen, even though remote user screen (1024x768) shows
normally.
3.
  
Actual results: Local user has missing parts of display


Expected results: Local user should have normal display


Additional info:Server machine is running f7 with kde desktop and using
widescreen monitor. Hardware profile
http://www.smolts.org/client/show?uuid=pub_21298b78-3386-45f0-8f1b-80fccf545429

Client machine is running f8 with kde desktop and using a non-widescreen monitor
(hardware profile
http://www.smolts.org/client/show?uuid=pub_8cb4b211-d13c-441d-ab8a-5bd25f5c3401

If the local user on the vnc server machine logs in with no vnc connection
running then the display returns to normal again.

The vnc server is loaded via xorg with lines in xorg.conf:
Section "Module"
        Load  "vnc"
EndSection

I am not sure if the entries in the last part of /var/log/messages are relevant
but here they are:
Apr 16 13:54:15 crc pcscd: winscard.c:219:SCardConnect() Reader E-Gate 0 0 Not Found
Apr 16 13:54:15 crc last message repeated 4 times
Apr 16 13:54:17 crc setroubleshoot: [rpc.ERROR] attempt to open server
connection failed: (2, 'No such fi
le or directory')
Apr 16 13:56:04 crc named[1689]: client 127.0.0.1#32776: RFC 1918 response from
Internet for 10.0.0.10.in
-addr.arpa
Apr 16 14:08:31 crc named[1689]: client 127.0.0.1#32781: RFC 1918 response from
Internet for 10.0.0.10.in
-addr.arpa
Apr 16 14:14:37 crc named[1689]: client 127.0.0.1#32782: RFC 1918 response from
Internet for 10.0.0.10.in
-addr.arpa
Apr 16 14:28:35 crc named[1689]: client 127.0.0.1#32789: RFC 1918 response from
Internet for 10.0.0.10.in
-addr.arpa

I will add relevant log files below.
Comment 1 Mike C 2008-04-16 10:04:02 EDT
The /var/log/kdm.log shows the following after starting and logging the local
user in via remote vnc session:

Build Date: 21 January 2008
Build ID: xorg-x11-server 1.3.0.0-16.fc7
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 16 13:42:18 2008
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
(II) Module already built-in

Wed Apr 16 13:42:18 2008
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5900
 vncext:      created VNC server for screen 0
Could not init font path element catalogue:/etc/X11/fontpath.d, removing from list!

Wed Apr 16 13:42:35 2008
 Connections: accepted: 127.0.0.1::43754
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 6 (8bpp) rgb222

Wed Apr 16 13:43:03 2008
 Connections: closed: 127.0.0.1::43754 (Clean disconnection)
 SMsgWriter:  framebuffer updates 137
 SMsgWriter:    ZRLE rects 377, bytes 142495
 SMsgWriter:    raw bytes equivalent 3210396, compression ratio 22.529885

Wed Apr 16 13:43:31 2008
 Connections: accepted: 127.0.0.1::43755
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)

Wed Apr 16 13:43:32 2008
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 6 (8bpp) rgb222

Wed Apr 16 13:43:42 2008
 Connections: closed: 127.0.0.1::43755 (Clean disconnection)
 SMsgWriter:  framebuffer updates 33
 SMsgWriter:    ZRLE rects 62, bytes 38220
 SMsgWriter:    raw bytes equivalent 1325144, compression ratio 34.671481

Wed Apr 16 13:48:06 2008
 Connections: accepted: 127.0.0.1::49848
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 6 (8bpp) rgb222

Wed Apr 16 13:52:39 2008
 vncext:      VNC extension running!
Could not init font path element catalogue:/etc/X11/fontpath.d, removing from list!

Wed Apr 16 13:52:55 2008
 Connections: closed: 127.0.0.1::49848 (Clean disconnection)
 SMsgWriter:  framebuffer updates 582
 SMsgWriter:    ZRLE rects 1397, bytes 641656
 SMsgWriter:    raw bytes equivalent 15689243, compression ratio 24.451175

Then after starting X again and logging in only with local user and not using
vnc the log has:

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux crc.mom.sapience.com 2.6.23.15-80.fc7 #1 SMP Sun
Feb 10 17:29:10 EST 2008
 i686
Build Date: 21 January 2008
Build ID: xorg-x11-server 1.3.0.0-16.fc7
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 16 13:53:29 2008
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
(II) Module already built-in

Wed Apr 16 13:53:30 2008
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5900
 vncext:      created VNC server for screen 0
Could not init font path element catalogue:/etc/X11/fontpath.d, removing from list!

Comment 2 Mike C 2008-04-16 10:04:54 EDT
Created attachment 302604 [details]
Xorg./log at the time when problems occured
Comment 3 Mike C 2008-04-16 10:05:42 EDT
Created attachment 302605 [details]
Xorg.log with the local user logging in on the server and no problems
Comment 4 Mike C 2008-04-16 10:06:18 EDT
Created attachment 302606 [details]
kdm.log when the problems occured
Comment 5 Mike C 2008-04-16 10:06:54 EDT
Created attachment 302607 [details]
kdm.log when local user logged in directly with no problems
Comment 6 Mike C 2008-04-16 10:45:15 EDT
Correction on display resolution at each end of the link - 

Rewmote client is 1280x1024
Local vnc server machine is 1680x1050
Comment 7 Mike C 2008-04-29 04:47:34 EDT
Further investigation shows that this peculiar phenomenon of losing part of the
screen display occurs when the local user alone is using the machine and
therefore this is not a vnc bug. This seems to be some kind of xorg problem and
therefore I am closing this bug, and will try to do further investigation to get
some diagnostics - if I can get some useful trace/log information then I will
open a bug on xorg.
Comment 8 Adam Tkac 2008-04-29 04:53:17 EDT
I haven't got time for this one yet but is this reproducable when you don't have
vnc module loaded?
Comment 9 Mike C 2008-04-29 12:13:09 EDT
The machine is in a town remote from my location so I don't have easy access to
it apart from ssh/vnc -  also in the next week or so the machine will be
replaced/retired so it will be almost impossible for me to test further after that.

The problem is sporadic and appears to occur at random with no obvious action
triggering the symptoms - this is when no vnc connection is being used from a
remote machine, but the vnc module is loaded and running in xorg. So this is
looking like a hardware fault which is one reason why the machine is going to be
replaced. If I do manage to get a chance and find any useful extra data I will
add to this report, but in the meantime unless anyone else can add to this I
will keep the bug closed.

Note You need to log in before you can comment on or make changes to this bug.