Bug 442728 - warnings in log / blank, empty startup page
warnings in log / blank, empty startup page
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: roundcubemail (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
: 444857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 09:59 EDT by Matthias Haase
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.1.1-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 03:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Haase 2008-04-16 09:59:21 EDT
Description of problem:
Some warnings and errors because required libraries are missing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install lastest 0.1.1 rpm for Fedora 8
2. 

a) warning in error log "PHP Notice: Could not convert encrypt password. Make
sure Mcrypt is installed or lib/des.inc is available in
/usr/share/roundcubemail/program/include/bugs.inc on line 95"
Message is gone after installing php-mcrypt - it should be added to Requires
section inside of the specfile (to dependencies). Apache must be restarted for
changes take effect...

b) /etc/roundcubemail/db.inc.php uses mdb2 but this library wasn't installed...
// database backend to use (only db or mdb2 are supported)
$rcmail_config['db_backend'] = 'mdb2';
Packages php-pear-MDB2 and php-pear-MDB2-Driver-mysql are required for this -
should be added to deps - otherwise 'mdb2' should be replaced by 'db' instead I
think...

3.
  
Actual results:
warnings in log / blank page at startup

Expected results:
No warnings / login page at starup

Additional info:
Comment 1 Gwyn Ciesla 2008-04-16 11:40:10 EDT
Built in rawhide, please test:
http://koji.fedoraproject.org/koji/buildinfo?buildID=46362
Comment 2 Gwyn Ciesla 2008-04-18 10:04:00 EDT
Reporter emial comment:
php-pecl-Fileinfo rpm is a Requirement too...


tail -f /var/log/httpd/error_log

does show php warning while using attachements....

[Fri Apr 18 10:22:57 2008] [error] [client 84.180.35.148] PHP Warning:  dl() [<a
href='function.dl'>function.dl</a>]: Unable to load dynamic library
'/usr/lib64/php/modules/fileinfo.so' - /usr/lib64/php/modules/fileinfo.so: Kann die
Shared-Object-Datei nicht \xf6ffnen: Datei oder Verzeichnis nicht gefunden in
/usr/share/roundcubemail/program/include/rcube_shared.inc on line 701, referer:
https://www.bennewitz.com/webmail/?_task=mail&_action=compose



New rawhide build fixing this:
http://koji.fedoraproject.org/koji/taskinfo?taskID=572193

Please test.
Comment 3 Gwyn Ciesla 2008-05-01 08:03:51 EDT
*** Bug 444857 has been marked as a duplicate of this bug. ***
Comment 4 Gwyn Ciesla 2008-05-19 11:25:16 EDT
Ok, since I've apparently been the only tester, but it works for me, I'll be
pushing this to 9, 8, and 7.
Comment 5 Fedora Update System 2008-05-19 13:42:03 EDT
roundcubemail-0.1.1-5.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-05-19 13:56:39 EDT
roundcubemail-0.1.1-5.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-05-21 06:59:39 EDT
roundcubemail-0.1.1-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update roundcubemail'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4201
Comment 8 Fedora Update System 2008-06-06 03:45:40 EDT
roundcubemail-0.1.1-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-06-06 03:49:39 EDT
roundcubemail-0.1.1-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.