Bug 442730 - virt-install swapping order of bridged networks
virt-install swapping order of bridged networks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 10:18 EDT by Nick Strugnell
Modified: 2009-12-14 16:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:22:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirt xml config to reproduce this (745 bytes, text/plain)
2008-06-24 17:00 EDT, Cole Robinson
no flags Details
Patch to honor xml ordering for net devices (583 bytes, patch)
2008-06-24 17:02 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description Nick Strugnell 2008-04-16 10:18:13 EDT
Description of problem:
We are using virt-install to install RHEL4U6 PV guests on a RHEL5.1 host.

We have two bridged networks, xenbr0 and xenbr1.

The networks are swapped round in the xen config file from the order they were
specified in the virt-install command. However, the kickstart still seems to
function through the first network


Version-Release number of selected component (if applicable):
python-virtinst-0.103.0-3.el5_1.1

How reproducible:
always

Steps to Reproduce:
1. Specify a virt-install command line like:

virt-install .... -x "ks=<blah> ksdevice=eth0" --network=bridge:xenbr0
--network=bridge:xenbr1


2. After installation, the xen config file will contain:

vif = [ "mac=00:16:3e:1c:de:6a,bridge=xenbr1",
"mac=00:16:3e:4d:98:77,bridge=xenbr0" ]

i.e. the NICs are swapped round.

3.
  
Actual results:
NIC swapped

Expected results:
NICs appear in correct order.

Additional info:

Workaround:

specify networks in inverse order in virt-install commandline.

Additionally, you will need to specify ksdevice=eth1 otherwise the kickstart
will be attempted through the wrong NIC.
Comment 1 Cole Robinson 2008-05-15 15:19:43 EDT
Can you post ~/.virtinst/virt-install.log? Thanks.
Comment 2 Cole Robinson 2008-05-15 15:21:17 EDT
Actually, if this is a 5.1 host, there won't be a log file I believe. If not,
can you post 'virsh dumpxml {guestname}'?
Comment 3 Nick Strugnell 2008-06-04 03:43:05 EDT
Sorry, no access to the system that we saw this bug on as saw it on a customer
site. Can you not reproduce?

Nick
Comment 4 Cole Robinson 2008-06-24 17:00:48 EDT
Created attachment 310185 [details]
libvirt xml config to reproduce this

This is a libvirt bug, it should honor the ordering of the devices in the xml
file. The above config can reproduce this.
Comment 5 Cole Robinson 2008-06-24 17:02:52 EDT
Created attachment 310186 [details]
Patch to honor xml ordering for net devices

Uses the same approach that libvirt uses to print disk devices to the xm
config.
Comment 6 Cole Robinson 2008-06-24 17:06:44 EDT
Ahh whoops, looks like this is already fixed upstream:

http://git.et.redhat.com/?p=libvirt.git;a=commitdiff;h=6fa538b08519147ea3ff932dfca02dcb9780b338
Comment 7 Daniel Veillard 2008-06-27 08:00:28 EDT
Okay problem is still present in libvirt-0.3.3-8 , this really need to be
fixed in 5.3, and the fix is trivial and tested for ages, please ACK :-)

Daniel
Comment 8 RHEL Product and Program Management 2008-06-27 08:07:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Daniel Veillard 2008-07-04 09:01:33 EDT
libvirt-0.3.3-10.el5 has been built in dist-5E-qu-candidate with the fix

Daniel
Comment 15 errata-xmlrpc 2009-01-20 16:22:29 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0142.html

Note You need to log in before you can comment on or make changes to this bug.