Bug 442750 - NameError: global name 'dispatch' is not defined
NameError: global name 'dispatch' is not defined
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.7
All Linux
high Severity high
: beta
: ---
Assigned To: Martin Sivák
Alexander Todorov
: Regression, TestBlocker
: 445502 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 12:21 EDT by James Laska
Modified: 2013-09-02 02:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0653
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg (894 bytes, text/plain)
2008-04-16 12:21 EDT, James Laska
no flags Details
anaconda.log (6.91 KB, text/plain)
2008-04-16 16:49 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-04-16 12:21:29 EDT
Description of problem:

Probing for video card:   NVIDIA Quadro NVS 285
Probing for monitor type:   AL2223W
Probing for mouse type:   Generic - 3 Button Mouse (PS/2)
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1088, in ?
    id = instClass.installDataClass(extraModules, floppyDevice, configFileData,
method)
  File "/usr/lib/anaconda/instdata.py", line 287, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 73, in reset
    self.diskset = partedUtils.DiskSet()
  File "/usr/lib/anaconda/partedUtils.py", line 552, in __init__
    self.dispatch = dispatch #dispatch is in __builtins__
NameError: global name 'dispatch' is not defined

Version-Release number of selected component (if applicable):

RHEL4-U7-re20080416.nightly/tree-Desktop-i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
 * I suspect there is a missing "import dispatch" stmt in this commit
http://git.fedorahosted.org/git/?p=anaconda.git;a=blobdiff;f=partedUtils.py;h=8281e2e1d5933649607083973e5d111d46c94f8a;hp=f5aa602bd3e00600965a874bc1cd7716c1f8545b;hb=eedc23707ecd0ae25433fa412a41ec4bf29a60cb;hpb=acab28e75d11b5ce7d9ece0cdf5a54391dea954b
Comment 1 James Laska 2008-04-16 12:21:29 EDT
Created attachment 302631 [details]
ks.cfg
Comment 3 James Laska 2008-04-16 16:49:07 EDT
Created attachment 302672 [details]
anaconda.log
Comment 4 Martin Sivák 2008-04-16 17:38:35 EDT
It is very likely related to one of my previous patches, so I will take care of
it. It seems that my __builtins__ method didn't prevent this as I hoped.
Comment 7 David Lehman 2008-04-18 11:46:53 EDT
Fixed in anaconda-10.1.1.86-1.
Comment 10 Joel Andres Granados 2008-05-07 04:55:57 EDT
*** Bug 445502 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2008-07-24 15:06:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0653.html

Note You need to log in before you can comment on or make changes to this bug.