Bug 442825 - qpidd server fails to start
qpidd server fails to start
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qpidc (Show other bugs)
8
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Nuno Santos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 22:48 EDT by Ed Hill
Modified: 2013-09-12 18:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 10:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adding path seems to fix things (405 bytes, patch)
2008-04-16 23:00 EDT, Ed Hill
no flags Details | Diff

  None (edit)
Description Ed Hill 2008-04-16 22:48:04 EDT
Description of problem:
server won't start

Version-Release number of selected component (if applicable):
qpidd-0.2-28.fc8.x86_64

How reproducible: 100%


Steps to Reproduce:
1. /etc/init.d/qpidd start
2. watch as it fails
3. 
  
Actual results:
[root@XXXXX]: /etc/init.d/qpidd start 
Starting Qpid AMQP daemon: -bash: qpidd: command not found
                                                           [FAILED]
Comment 1 Ed Hill 2008-04-16 23:00:52 EDT
Created attachment 302692 [details]
adding path seems to fix things

I don't know what the default set of paths are supposed to be in 
sysv-style init scripts but adding /usr/sbin/ seems to help here.
Comment 2 Nuno Santos 2008-04-17 01:09:55 EDT
I've been unable to reproduce the problem with the 0.2-28 rpm:

$ cat /etc/redhat-release
Fedora release 8 (Werewolf)
$ rpm -qa | grep qpid
$ sudo yum install qpidd
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package qpidd.i386 0:0.2-28.fc8 set to be updated
--> Processing Dependency: qpidc = 0.2-28.fc8 for package: qpidd
--> Processing Dependency: libqpidcommon.so.0 for package: qpidd
--> Running transaction check
---> Package qpidc.i386 0:0.2-28.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 qpidd                   i386       0.2-28.fc8       updates           654 k
Installing for dependencies:
 qpidc                   i386       0.2-28.fc8       updates           995 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 1.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): qpidc-0.2-28.fc8.i 100% |=========================| 995 kB    00:00
(2/2): qpidd-0.2-28.fc8.i 100% |=========================| 654 kB    00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: qpidc                        ######################### [1/2]
  Installing: qpidd                        ######################### [2/2]

Installed: qpidd.i386 0:0.2-28.fc8
Dependency Installed: qpidc.i386 0:0.2-28.fc8
Complete!
$ sudo /etc/init.d/qpidd start
Starting Qpid AMQP daemon:                                 [  OK  ]
$
$ sudo /etc/init.d/qpidd stop
Stopping Qpid AMQP daemon:                                 [  OK  ]
$
Comment 3 Ed Hill 2008-04-17 09:13:16 EDT
It fails for me in exactly the same way on two machines and I'll be 
happy to try a third.  Note that both of these machines are relatively
pristine installs.

[root@sekhmet ~]# yum clean all
Cleaning up Everything
[root@sekhmet ~]# yum install qpidd
fedora                    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 5.8 MB    00:16     
updates                   100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 2.6 MB    00:06     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package qpidd.x86_64 0:0.2-28.fc8 set to be updated
--> Processing Dependency: qpidc = 0.2-28.fc8 for package: qpidd
--> Processing Dependency: libqpidcommon.so.0()(64bit) for package: qpidd
--> Processing Dependency: openais for package: qpidd
---> Package qpidd.i386 0:0.2-28.fc8 set to be updated
--> Processing Dependency: libqpidcommon.so.0 for package: qpidd
--> Running transaction check
---> Package qpidc.x86_64 0:0.2-28.fc8 set to be updated
---> Package qpidc.i386 0:0.2-28.fc8 set to be updated
---> Package openais.x86_64 0:0.80.1-6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 qpidd                   x86_64     0.2-28.fc8       updates           652 k
 qpidd                   i386       0.2-28.fc8       updates           654 k
Installing for dependencies:
 openais                 x86_64     0.80.1-6         fedora            364 k
 qpidc                   x86_64     0.2-28.fc8       updates           1.0 M
 qpidc                   i386       0.2-28.fc8       updates           995 k

Transaction Summary
=============================================================================
Install      5 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 3.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): openais-0.80.1-6.x 100% |=========================| 364 kB    00:01     
(2/5): qpidc-0.2-28.fc8.i 100% |=========================| 995 kB    00:03     
(3/5): qpidd-0.2-28.fc8.i 100% |=========================| 654 kB    00:01     
(4/5): qpidd-0.2-28.fc8.x 100% |=========================| 652 kB    00:01     
(5/5): qpidc-0.2-28.fc8.x 100% |=========================| 1.0 MB    00:03     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: openais                      ######################### [1/5] 
  Installing: qpidc                        ######################### [2/5] 
  Installing: qpidc                        ######################### [3/5] 
  Installing: qpidd                        ######################### [4/5] 
  Installing: qpidd                        ######################### [5/5] 

Installed: qpidd.x86_64 0:0.2-28.fc8 qpidd.i386 0:0.2-28.fc8
Dependency Installed: openais.x86_64 0:0.80.1-6 qpidc.x86_64 0:0.2-28.fc8
qpidc.i386 0:0.2-28.fc8
Complete!
[root@sekhmet ~]# /etc/init.d/qpidd status
qpidd is stopped
[root@sekhmet ~]# /etc/init.d/qpidd start 
Starting Qpid AMQP daemon: -bash: qpidd: command not found
                                                           [FAILED]
[root@sekhmet ~]# 

Comment 4 Ed Hill 2008-04-17 09:23:18 EDT
It does not appear to be a sudo issue.  I just tried the sudo version of 
the above and got the same result:

[sekhmet ~]: uname -a 
Linux sekhmet.XXX.YYY 2.6.24.4-64.fc8 #1 SMP Sat Mar 29 09:15:49 EDT 2008 x86_64
x86_64 x86_64 GNU/Linux
[sekhmet ~]: sudo /etc/init.d/qpidd start 
Starting Qpid AMQP daemon: -bash: qpidd: command not found
                                                           [FAILED]
[sekhmet ~]: 


Please note that I have not done anything on either machine to change 
root's path or other environment settings.  In both cases, root's 
environment is the default.

And, as mentioned in comment #1, I do not understand the path "rules" for 
sysv-style init files.  Perhaps someone who has more experience with them 
could please explain what is happening here?
Comment 5 Nuno Santos 2008-04-17 10:28:31 EDT
Ed: you're right that it may be due to a modified system configuration... since
adding the path as per your patch won't have any negative side effects, I'm
going to go ahead and do that. Will post again once there's an updated rpm
available.
Comment 6 Fedora Update System 2008-04-17 14:10:23 EDT
qpidc-0.2-29.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-04-17 14:35:25 EDT
qpidc-0.2-29.fc7 has been submitted as an update for Fedora 7
Comment 8 Ed Hill 2008-04-17 18:36:30 EDT
Hi Nuno, thank you for putting together a fix.  I'm enthused about qpid
and am hoping that others at work will be willing to try it (and if its 
easy to use that helps!).

Here is a closer look at the sys-v script: within the daemon() function, 
the following line triggers the error for me:

  $nice runuser -s /bin/bash - $user -c "$corelimit >/dev/null 2>&1 ; $*"

After variable expansion, that line is:

  runuser -s /bin/bash - qpidd  \
    -c "ulimit -S -c 0 >/dev/null 2>&1 ; qpidd --daemon"

If I log in as root and run this similar command then the results are:

  [root@sekhmet ~]# runuser -s /bin/bash - qpidd -c "which qpidd"
  which: no qpidd in
(/usr/lib64/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/var/lib/qpidd/bin)
  [root@sekhmet ~]# 

which shows that the runuser command is correctly using qpidd's default 
(login) PATH which does not include /usr/sbin.

So, I'm wondering -- what was qpidd's default (login) PATH on your system?
Comment 9 Fedora Update System 2008-04-22 18:42:31 EDT
qpidc-0.2-29.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-04-22 18:45:20 EDT
qpidc-0.2-29.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Ed Hill 2008-07-06 10:59:35 EDT
With the F8 update this problem has been fixed for me.  Thank you!

Note You need to log in before you can comment on or make changes to this bug.