Bug 442860 - Gecko engine and X -> high load
Gecko engine and X -> high load
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 04:53 EDT by Christoph Höger
Modified: 2008-09-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 12:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf from fedora 8 (1.07 KB, application/octet-stream)
2008-09-10 17:46 EDT, Christoph Höger
no flags Details

  None (edit)
Description Christoph Höger 2008-04-17 04:53:13 EDT
Description of problem:
Rendering some websites using Gecko (Firefox & Epiphany) causes the X-Server to
have extremely high cpu usage.
Tested with http://nooners.de which causes firefox between 60% and 100% of cpu
usage, while konqueror renders smoothly with 5%-10%.
This happens on my notebook with ATI x1400 (fglrx, radeon, radeonhd tested) and
on my desktop (nvidia) - so its propably not a driver/hardware thing. 

Version-Release number of selected component (if applicable):
firefox-2.0.0.13-1.fc8
xorg-x11-server-Xorg-1.3.0.0-44.fc8


How reproducible:
always

Steps to Reproduce:
1. open firefox
2. open top
3. surf to a site where images are moving around (e.g. http://nooners.de - this
site brought me to that bug, as I wrote it ;) )
  
Actual results:
X turns to use up to 100% of CPU

Expected results:
X should not use more than 10% especially with DRI activated

Additional info:
This site runs fine on some debian systems (using ff2 & ff3)
example conf.:
ii  xserver-xorg   1:7.2-5        the X.Org X server
ii  iceweasel      2.0.0.12-1     lightweight web browser based on Mozilla
Comment 1 Matěj Cepl 2008-07-25 11:39:27 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Christoph Höger 2008-09-10 17:45:39 EDT
Sorry for the late response, I simply forgot about that issue, as the combination of f9/new laptop/ff3 fixed it for me.
For you information here is my xorg.conf.
Comment 3 Christoph Höger 2008-09-10 17:46:25 EDT
Created attachment 316360 [details]
xorg.conf from fedora 8
Comment 4 Matěj Cepl 2008-09-18 11:52:22 EDT
(In reply to comment #2)
> Sorry for the late response, I simply forgot about that issue, as the
> combination of f9/new laptop/ff3 fixed it for me.
> For you information here is my xorg.conf.

Cool, so does it mean that you could close this bug as fixed somewhere in F9 range?
Comment 5 Christoph Höger 2008-09-18 12:46:08 EDT
I think NEXTRELEASE should be the correct reason to close this bug.

Note You need to log in before you can comment on or make changes to this bug.