This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 4429 - TCSH history doesn't work on a Alpha DP264.
TCSH history doesn't work on a Alpha DP264.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
6.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-08 17:57 EDT by niles
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-10 15:16:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description niles 1999-08-08 17:57:57 EDT
tcsh history is broken. Even if I do "source -h .cshrc" the
history will still be blank with "set history=1000", If I
"set history=10" it will remember what I "source -h" but not
any commands I type.  bash works perfect.

I believe this is a 21264 specific problem as it does not
occur on my 21064.  It may even be a SMP 21264 unique
problem.  I've also tried rebuilding tcsh from SRPM using
the patched egcs compiler to no avail.
Comment 1 niles 1999-08-22 10:00:59 EDT
The fact that history didn't work at all was because of bug #3686.
It was the bugs in the kde scripts (kdesupport).  After applying
fixes for bug #3686 history works for the current session.

However, I do notice that history is still not preserved between
sessions.  It this just a configuration change?
Comment 2 Preston Brown 1999-08-23 11:32:59 EDT
do you have a ~/.history file?
Comment 3 niles 1999-08-23 21:45:59 EDT
I had to add both a ~/.history file and "set savehist=1" to get
it to work between sessions.  I've never had to do this under
Redhat/i386.  Funny...oh well. Thanks!
Comment 4 Jeff Johnson 2000-01-10 15:16:59 EST
This problem appears to be reolved. Please reopen if I'm wriong.

Note You need to log in before you can comment on or make changes to this bug.