Bug 442912 - Kdump panics by vmcore copy when system uses booting from SAN
Kdump panics by vmcore copy when system uses booting from SAN
Status: CLOSED DUPLICATE of bug 237950
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 11:27 EDT by Lumir Unzeitig
Modified: 2009-09-09 01:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 10:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lumir Unzeitig 2008-04-17 11:27:11 EDT
Description of problem:
Kdump panics when tries to copy /proc/vmcore to a location (/var/crash or a
server via scp). 
The kexec boots the right kernel nad ramdisk, the vmcore file is located in
/proc, but the "cp" command in /etc/init.d/kdump file (save_core func) initiates
panic.
This behaviour happens on all 5 Linux systems which booting from the SAN. The
others booted by local disks are OK.

----------
EDAC k8 MC0: GART TLB errorr: transaction type(generic), cache level(generic)
EDAC k8 MC0: extended error code: GART error
Kernel panic - not syncingL MC: processor context corrupt
----------


Version-Release number of selected component (if applicable):
kexec: 1-1.0.1-164.el5
qla2xxx: 8.01.07.15 (source:QLogic)



How reproducible:
100% in our configuration

Steps to Reproduce:
1. Set up crashkernel=512M@16M for kernel
2. Start the kdump service
3. Initiate panic echo c > /proc/sysrq-trigger
  
Actual results:
Vmcore file is created but not copied out of /proc.

Expected results:
Vmcore file is copied to selected destination and sytem is rebooted.

Additional info:
HW: Fujitsu-Siemens, BladeSever BX630-S2 (4x DualCore AMD Proc 885), 8{32}GB
RAM, HBA QLogic ISP23xx
Comment 1 Neil Horman 2008-04-17 11:56:35 EDT
The error that you indicate above is fixed in kernel 2.6.18-34.el5.  If you
upgrade to that kernel or later, and specify the reset_devices commandline
option in /etc/sysconfig/kdump, you're problem should clear up.  Please confirm.
 Thanks!
Comment 2 Lumir Unzeitig 2008-04-22 07:18:13 EDT
Thanks for quik reposnse. Unfortunatelly I cannot upgrade the kernel because
there are piece of sw dependending on the kernel version (cluster,volume manager
(veritas), file system (veritas) ).
Does a workaround exist for getting the crashdump manually? Thanks for your answer.
Comment 3 Neil Horman 2008-04-22 10:05:29 EDT
sorry, you need the latest kernel package.    Its bz 237950 if you want to look
at it, but if you can't upgrade to the latest kernel package, there isn't really
any workaround.

*** This bug has been marked as a duplicate of 237950 ***

Note You need to log in before you can comment on or make changes to this bug.