Bug 443035 - modifyrepo changes overwritten by createrepo --update
modifyrepo changes overwritten by createrepo --update
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: createrepo (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: packaging-team-maint
:
Depends On:
Blocks: 730340
  Show dependency treegraph
 
Reported: 2008-04-18 06:49 EDT by Jan Hutař
Modified: 2013-03-14 15:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 730340 (view as bug list)
Environment:
Last Closed: 2013-03-14 15:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-04-18 06:49:00 EDT
Description of problem:
When I add some file to the repos repodata and then calls `createrepo --
update`, repomd.xml is overwritten and do not contain file added by modifrepo.


Version-Release number of selected component (if applicable):
createrepo-0.4.11-1.el5.noarch


How reproducible:
always


Steps to Reproduce:
1. # modifyrepo my_file.txt $REPO_DIR/repodata
2. # createrepo --database --update $REPO_DIR
3. # grep my_file.txt $REPO_DIR/repodata/repomd.xml


Actual results:
my_file.txt is not listed in the $REPO_DIR/repodata/repomd.xml


Expected results:
my_file.txt is listed in the $REPO_DIR/repodata/repomd.xml


Additional info:
I'm not sure if this is a bug, or if this is an expected behaviour.
Comment 2 Karel Srot 2011-08-12 10:27:45 EDT
Just found this old bug that wasn't tagged properly and therefore lost.
Comment 3 RHEL Product and Program Management 2011-09-22 20:33:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 James Antill 2013-03-14 15:58:01 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.

Note You need to log in before you can comment on or make changes to this bug.