Bug 443101 - repoquery: traceback on unsupported tag
repoquery: traceback on unsupported tag
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 13:04 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 15:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-18 13:04:53 EDT
Description of problem:


[root@localhost ~]# repoquery  -q --qf "%{NAME} %{BUILDDATE}\n" thunderbird
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 829, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 826, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 473, in runQuery
    print pkg.doQuery(oper)
  File "/usr/bin/repoquery", line 160, in doQuery
    return getattr(self, "fmt_%s" % method)(*args, **kw)
  File "/usr/bin/repoquery", line 190, in fmt_queryformat
    return fmt % self
  File "/usr/bin/repoquery", line 142, in __getitem__
    res = self.pkg.returnSimple(item)
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 208, in returnSimple
    return getattr(self, varname)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 134, in
__getattr__
    (self.pkgId,)).fetchone()
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 41, in newFunc
    raise Errors.RepoError
yum.Errors.RepoError: None

Version-Release number of selected component (if applicable):

yum-utils-1.1.13-2.fc9.noarch
Comment 1 James Antill 2008-04-18 13:21:14 EDT
 We can't just catch RepoError ... so the only thing that comes to mind is to do
a whitelist of valid tags, which sucks (although that would give us a nice way
to list all valid tags).
 I guess we could start throwing something specific, for just this error. Meh.
Comment 2 James Antill 2008-04-18 13:22:02 EDT
 Nevermind ... we apparently already have a whitelist ... so easy fix.
Comment 3 Seth Vidal 2008-04-18 15:17:29 EDT
the problem is YumInstalledPackages raised a different exception than
YumAvailablePackages b/c of a global sqlite exception catch. I've made a fix for
this and now repoquery acts correctly. next release of yum will fix this.


Note You need to log in before you can comment on or make changes to this bug.