Bug 443131 - encryption support failing
encryption support failing
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-18 15:29 EDT by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-04 10:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-04-18 15:29:17 EDT
Description of problem:

Encryption support has been failing on my system on beta as well as the recent
preview release. I don't see any initrd files under /boot in the system. I am
booting from a bootable USB created from the desktop live image. I haven't tried
other methods.
Comment 1 Jeremy Katz 2008-04-21 19:48:06 EDT
Can you provide the install.log and anaconda.log from the install?
Comment 2 Bug Zapper 2008-05-14 05:40:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 3 Dave 2008-05-14 14:41:46 EDT
I am experiencing the same problem with the RELEASE version of Fedora-9-Live-686.

I used the Live spin and installed to a 4 GB thumb drive. Manually created
"/boot" and "/" partitions with "/" set as encrypted. (Also tried it with and
without a small "swap" partition.) 

The installation appears to install fine. I can mount the encrypted partitions
on a Fedora-8 system by supplying the encryption password at the prompt upon
plugging in the thumb drive.

Booting from this thumb drive starts normally, then prompts for the encryption
password. After typing the password and hitting enter, it insists that no
matching key was found and freezes.
Comment 4 David Lehman 2008-05-14 14:52:21 EDT
Can someone who is having this problem please upload install.log and
anaconda.log from install?
Comment 5 Dave 2008-05-15 11:12:34 EDT
Got it working!

I haven't worked out exactly what went wrong, but it was definitely the boot
loader step.

I made the thumb drive the only available installation drive by removing access
to the hard drive. The thumb drive was seen by the Live installer as SDA and
everything worked!

It's possible that I simply messed up the boot selector step, but I didn't think
Comment 6 Andy Lindeberg 2008-06-03 10:11:38 EDT
Still in need of anaconda.log and install.log from anybody having this problem.

Note You need to log in before you can comment on or make changes to this bug.