Bug 443178 - Konqueror defaults to IPv4 on v4 & v6 DNS records.
Konqueror defaults to IPv4 on v4 & v6 DNS records.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 18:59 EDT by Marcin Łabanowski
Modified: 2008-04-18 20:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 19:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcin Łabanowski 2008-04-18 18:59:06 EDT
Description of problem:
While loading websites which have both A and AAAA records, Konqueror 4 connects
to the website using IPv4, while other browsers (Konqueror 3.5, Firefox 3, lynx
2.8.6-13, ...) use IPv4. I've also tested QtLauncher from
WebKit-qt-1.0.0-0.8.svn31787.fc9 and the same happened, so it appears it is qt's
fault.

The IPv6 connection works for sure and Konqueror CAN connect to IPv6 hosts when
you give it an IPv6-only record.

Version-Release number of selected component (if applicable):
qt-4.3.4-11.fc9
(another mentioned:
WebKit-qt-1.0.0-0.8.svn31787.fc9
kdebase-4.0.3-7.fc9
kdelibs-4.0.3-6.fc9
)

Steps to Reproduce:
1. Get IPv6 access from somewhere if you don't have already. I have it from radvd.
2. Start Konqueror / QtLauncher
3. Point your browser to, for example: http://rydzyk.net/whoami.php
  
Actual results:
79.185.(...) - (...).neoplus.adsl.tpnet.pl

Expected results:
2001:6a0:(...) - (...).net

Additional info:
It is my first bug report here, so I don't know if it's filled right and the
component is chosen right (the bug is itself in qt, but it's most annoying in
Konqueror). I didn't report it upstream, because I'm not sure it isn't
configuration's fault. Thank you for help.
Comment 1 Kevin Kofler 2008-04-18 19:07:46 EDT
How's this a bug? IPv4 is usually preferred if both are available because it's 
more likely to work in the real world. (Applications preferring IPv6 over IPv4 
have been the subject of lengthy flamewars on the mailing lists. There are many 
broken networks where IPv6 is supported up to some point and then eaten before 
it actually reaches the Internet.) As long as IPv6-only sites resolve properly, 
I fail to see where the bug is.
Comment 2 Marcin Łabanowski 2008-04-18 19:30:59 EDT
Thank you for your interest. For me it is a bug, as I'm used to the previous
behaviour and most applications still prefer IPv6. In my opinion if IPv6 is
broken somewhere it's better to turn it off globally (inconfig) than rely on it
for some apps and for some not. After more searching I've found, that it is
fixed upstream in Qt 4.4[1].

[1] http://trolltech.com/developer/task-tracker/index_html?method=entry&id=194539
Comment 3 Kevin Kofler 2008-04-18 19:37:02 EDT
Interesting. Let's see when/if the "regression!!!" complaints start coming in 
once we upgrade to 4.4. We may have to revert this change. Or we may not.
Comment 4 Rex Dieter 2008-04-18 20:31:55 EDT
chax, thanks for the input, and I think your expectations are correct, afaik,
konq is supposed to prefer ipv6.  However, to get this the proper attention it
deserves, it ought to be reported to bugs.kde.org, so upstream developers can
comment.  When/if you do, please let us know the bug #, so that we can continue
to track the issue there.
Comment 5 Rex Dieter 2008-04-18 20:33:36 EDT
ok, duh, didn't parse comment #2 , looks like it's already being addressed.

Note You need to log in before you can comment on or make changes to this bug.